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Introduction

Self-service business intelligence (BI)—you have heard the hype, seen the sales demos, and are ready to 
give it a try. Now what? You have probably checked out a few web sites for examples, given them a try, and 
learned a thing or two, but you are probably still left wondering how all the pieces fit together and how you 
go about creating a complete solution. If so, this book is for you. It takes you step by step through the process 
of analyzing data using the tools that are at the core of Microsoft’s self-service BI offering: Power Query, 
Power Pivot, and Power BI.

Quite often, you need to take your raw data and transform it in some way before you load it into the data 
model. You may need to filter, aggregate, or clean the raw data. I show you how Power Query allows you to 
easily transform and refine data before incorporating it into your data model. Next, I show you how to create 
robust, scalable data models using Power Pivot. Because Power Pivot is the core tool you will use to create 
self-service BI solutions, I cover it extensively in this book. Next up, I show you how to use Power BI Desktop 
to easily build interactive visualizations that allow you to explore your data to discover trends and gain 
insight. Finally, I show you how to deploy your solution to the Power BI Service for your colleagues to use.

I strongly believe that one of the most important aspects of learning is doing. You can’t learn how to ride 
a bike without jumping on a bike, and you can’t learn to use the BI tools without actually interacting with 
them. Any successful training program includes both theory and hands-on activities. For this reason, I have 
included a hands-on activity at the end of every chapter designed to solidify the concepts covered in the 
chapter. I encourage you to work through these activities diligently. It is well worth the effort.
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CHAPTER 1

Introducing Power Pivot

The core of Microsoft’s self-service business intelligence (BI) toolset is Power Pivot. It is integrated into both 
Excel 2016 and Power BI and forms the foundation on top of which you will build your analytical reports and 
dashboards. This chapter provides you with some background information on why Power Pivot is such an 
important tool and what makes it perform so well. The chapter also provides you with an overview of the Power 
Pivot interface in Excel 2016 and gives you with some experience using the different areas of the interface.

After reading this chapter you will be familiar with the following:

•	 Why you should use Power Pivot

•	 The xVelocity in-memory analytics engine

•	 Exploring the Data Model Management interface

•	 Analyzing data using a pivot table

Why Use Power Pivot?
You may have been involved in a traditional BI project consisting of a centralized data warehouse where 
the various data stores of the organization are loaded, scrubbed, and then moved to an online analytical 
processing (OLAP) database for reporting and analysis. Some goals of this approach are to create a data 
repository for historical data, create one version of the truth, reduce silos of data, clean the company data 
and make sure it conforms to standards, and provide insight into data trends through dashboards. Although 
these are admirable goals and are great reasons to provide a centralized data warehouse, there are some 
downsides to this approach. The most notable is the complexity of building the system and implementing 
change. Ask anyone who has tried to get new fields or measures added to an enterprise-wide data 
warehouse. Typically, this is a long, drawn-out process requiring IT involvement along with data steward 
committee reviews, development, and testing cycles.

What is needed is a solution that allows for agile data analysis without so much reliance on IT and 
formalized processes. To solve these problems, many business analysts have used Excel to create pivot tables 
and perform ad hoc analysis on sets of data gleaned from various data sources. Some problems with using 
isolated Excel workbooks for analysis are conflicting versions of the truth, silos of data, and data security.

So how can you solve this dilemma of the centralized data warehouse being too rigid while the Excel 
solution is too loose? This is where Microsoft’s self-service BI toolset comes in. These tools do not replace 
your centralized data warehouse solution but rather augment it to promote agile data analysis. Using Power 
Pivot, you can pull data from the data warehouse, extend it with other sources of data such as text files or 
web data feeds, build custom measures, and analyze the data using pivot tables and pivot charts. You can 
create quick proofs of concepts that can be easily promoted to become part of the enterprise-wide solution. 
Power Pivot also promotes one-off data analysis projects without the overhead of a drawn-out development 
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cycle. When combined with SharePoint 2016, SQL Server Reporting Services 2016, and/or One Drive, 
workbooks can be shared, secured, and managed. This goes a long way to satisfying IT’s need for governance 
without impeding the business user’s need for agility.

Here are some of the benefits of Power Pivot:

•	 Functions as a free add-in to Excel

•	 Easily integrates data from a variety of sources

•	 Handles large amounts of data, upward of tens to hundreds of millions of rows

•	 Uses familiar Excel pivot tables and pivot charts for data analysis

•	 Includes a powerful Data Analysis Expressions (DAX) language

•	 Has data in the model that is read only, which increases security and integrity

When Excel Power Pivot workbooks are hosted in SharePoint, Reporting Services, and/or One Drive, 
here are some of its added benefits:

•	 Enables the sharing and collaboration of Excel Power Pivot solutions

•	 Can schedule and automate data refresh

•	 Can audit changes through version management

•	 Can secure users for read-only and updateable access

Now that you know some of the benefits of Power Pivot, let’s see what makes it tick.

The xVelocity In-memory Analytics Engine
The special sauce behind Power Pivot is the xVelocity in-memory analytics engine (yes, that is really the 
name). xVelocity allows Power Pivot to provide fast performance on large amounts of data. One of the keys to 
this is it uses a columnar database to store the data. Traditional row-based data storage stores all the data in 
the row together and is efficient at retrieving and updating data based on the row key, for example, updating 
or retrieving an order based on an order ID. This is great for the order-entry system but not so great when you 
want to perform analysis on historical orders (say you want to look at trends for the past year to determine 
how products are selling, for example). Row-based storage also takes up more space by repeating values for 
each row; if you have a large number of customers, common names like John or Smith are repeated many 
times. A columnar database stores only the distinct values for each column and then stores the row as a set 
of pointers back to the column values. This built-in indexing saves a lot of space and allows for significant 
optimization when coupled with data-compression techniques that are built into the xVelocity engine. It also 
means that data aggregations (like those used in typical data analysis) of the column values are extremely fast.

Another benefit provided by the xVelocity engine is the in-memory analytics. Most processing 
bottlenecks associated with querying data occur when data is read from or written to a disk. With in-memory 
analytics, the data is loaded into the RAM memory of the computer and then queried. This results in 
much faster processing times and limits the need to store pre-aggregated values on disk. This advantage 
is especially apparent when you move from 32-bit to 64-bit operating systems and applications, which are 
becoming the norm these days.
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Another benefit worth mentioning is the tabular structure of the Power Pivot model. The model consists 
of tables and table relationships. This tabular model is familiar to most business analysts and database 
developers. Traditional OLAP databases such as SQL Server Analysis Server (SSAS) present the data model 
as a three-dimensional cube structure that is difficult to work with and requires a complex query language 
called Multidimensional Expressions (MDX). I find that in most cases (but not all), it is easier to work with 
tabular models and DAX than OLAP cubes and MDX.

Enabling Power Pivot for Excel
Power Pivot is a free add-in to Excel and has been available since Excel 2010. If you are using Excel 2010, you 
have to download and install the add-in from the Microsoft Office website. If you are using Excel 2013, the 
add-in is already installed and you just have to enable it. If you are using Excel 2016 (the version covered in 
this book), it is already installed and enabled for you. To check what edition you have installed, click the File 
menu in Excel and select the Account tab, as shown in Figure 1-1.

Figure 1-1.  Checking for the Excel version
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On the Account tab, click the About Excel button. You are presented with a screen showing version 
details, as shown in Figure 1-2. Take note of the edition and the version. Although the 32-bit version will 
work fine for smaller data sets, to get the optimal performance and experience from Power Pivot you should 
use the 64-bit version running on a 64-bit version of Windows with at least 8 GB of RAM.

Figure 1-2.  Checking the Excel edition and version
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Once you have determined that you are running the correct version, you can enable/disable the Power 
Pivot add-in by clicking the File menu and selecting the Options tab. In the Excel Options window, click the 
Add-Ins tab. In the Manage drop-down select COM Add-ins and click the Go button (see Figure 1-3).

Figure 1-3.  Managing COM add-ins
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You are presented with the COM Add-ins window (see Figure 1-4). Make sure Microsoft Power Pivot for 
Excel is checked and click OK.

Now that you have ensured that the Power Pivot add-in for Excel is enabled, it is time to explore the 
Data Model Manager.

Exploring the Data Model Manager Interface
If Power Pivot is enabled, you should see a Power Pivot tab in Excel (see Figure 1-5). Clicking the Manage 
button launches the Data Model Management interface.

When the Data Model Manager launches, you will have two separate but connected interfaces. You can 
switch back and forth between the normal Excel interface and the Data Model Management interface. This 
can be quite confusing for new Power Pivot users. Remember, the Data Model Manager (Figure 1-6) is where 
you define the model including tables, table relationships, measures, calculated columns, and hierarchies. 
The Excel interface (Figure 1-7) is where you analyze the data using pivot tables and pivot charts.

Figure 1-4.  Selecting the Power Pivot add-in

Figure 1-5.  Launching the Data Model Manager
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Figure 1-6.  The Data Model Manager interface

Figure 1-7.  The Excel Workbook interface
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There are two views of the data model in the Data Model Manager: the data view and the diagram view. 
When it first comes up, it is in the data view mode. In data view mode, you can see the data contained in the 
model. Each table in the model has its own tab in the view. Tables can include columns of data retrieved 
from a data source and also columns that are calculated using DAX. The calculated columns appear a little 
darker and have a different-colored header than the other columns. Figure 1-8 shows the Full Name column, 
which is derived by concatenating the First Name and Last Name columns.

Each tab also contains a grid area below the column data. The grid area is where you define measures 
in the model. The measures usually consist of some sort of aggregation function. For example, you may want 
to look at sales rolled up by month or by products. Figure 1-9 shows some measures associated with the 
Internet Sales table.

Figure 1-8.  A calculated column in the Data Model Manager
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There are four menu tabs at the top of the designer: File, Home, Design, and Advanced. If you don’t see 
the Advanced tab, you can show it by clicking the File menu tab and selecting Switch To Advanced Mode. 
You will become intimately familiar with the menus in the designer as you progress through this book. 
For now, suffice it to say that this is where you initiate various actions such as connecting to data sources, 
creating data queries, formatting data, setting default properties, and creating key performance indicators 
(KPIs). Figure 1-10 shows the Home menu in the Data Model Manager.

On the right side of the Home menu you can switch from the data view mode to the diagram view 
mode. The diagram view shown in Figure 1-11 illustrates the tables and the relationships between the tables. 
This is where you generally go to establish relationships between tables and create hierarchies for drilling 
through the model. The menus are much the same in both the data view and the diagram view. You will 
find, however, that some things can only be done in the data view, and some things can only be done in the 
diagram view.

Figure 1-9.  The measures grid area in the Data Model Manager

Figure 1-10.  The Home menu tab in the Data Model Manager
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Now that you are familiar with the various parts of the Data Model Manager, it’s time to get your hands 
dirty and complete the following hands-on lab. This lab will help you become familiar with working in the 
Data Model Manager.

■■ Note   To complete the labs in this book, make sure you download the starter files from https://github.com/ 
Apress/beginning-power-bi-2ed.

Figure 1-11.  Using the diagram view in the Data Model Manager

https://github.com/Apress/beginning-power-bi-2ed
https://github.com/Apress/beginning-power-bi-2ed
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HANDS-ON LAB: EXPLORING POWER PIVOT

In this following lab you will

•	 Verify that the Power Pivot add-in is enabled.

•	 Analyze data using pivot tables.

•	 Explore the Data Model Manager.

1.	 Open Excel 2016.

2.	 On the File menu, select Account (refer to Figure 1-1).

3.	 Click About Excel and check the version (32-bit or 64-bit) you are using.

4.	 On the File menu select Options and then click the Add-Ins tab. In the Manage 
drop-down, select COM Add-ins and click Go.

5.	 In the COM Add-ins window, make sure the Power Pivot add-in (refer to Figure 1-4) 
is checked. 

6.	 Open the Chapter1Lab1.xlsx file located in the LabStarterFiles folder.

7.	 Click Sheet1. You should see a basic pivot table showing sales by year and country, 
as shown in Figure 1-12.

Figure 1-12.  Using a pivot table
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8.	 Click anywhere in the pivot table. You should see the field list on the right side, as 
shown in Figure 1-13. 

9.	 Below the field list are the drop areas for the filters, rows, columns, and values. You 
drag and drop the fields into these areas to create the pivot table.

10.	 Click the All tab at the top of the PivotTable Fields window. Expand the Product table in 
the field list. Find the Product Category field and drag it to the Report Filter drop zone.

11.	 A filter drop-down appears above the pivot table. Click the drop-down filter icon. 
You should see Product Categories.

12.	 Change the filter to Bikes and notice the values changing in the pivot table.

13.	 When you select multiple items from a filter, it’s hard to tell what is being filtered on. 
Filter on Bikes and Clothing. Notice that when the filter drop-down closes, it just shows 
(Multiple Items). Remove the Product Category field from the Report Filter drop zone.

Figure 1-13.  The pivot table field list
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14.	 Slicers act as filters but they give you a visual to easily determine what is selected. On the 
Insert menu, click the Slicer. In the pop-up window that appears, select the All tab and then 
select the Category hierarchy under the Product table, as shown in Figure 1-14. 

15.	 Product Category and Product Subcategory slicers are inserted and are used to 
filter the pivot table. To filter by a value, click the value button. To select multiple 
buttons, hold down the Ctrl key while clicking (see Figure 1-15). Notice that 
because these fields were set up as a hierarchy, selecting a product category 
automatically filters to the related subcategories in the Product Subcategory slicer. 

Figure 1-14.  Selecting slicer fields
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16.	 Hierarchies are groups of columns arranged in levels that make it easier to navigate 
the data. For example, if you expand the Date table in the field list, you can see the 
Calendar hierarchy, as shown in Figure 1-16. This hierarchy consists of the Year, 
Quarter, and Month fields and represents a natural way to drill down into the data.

Figure 1-15.  Using slicers to filter a pivot table

Figure 1-16.  Using hierarchies in a pivot table



Chapter 1 ■ Introducing Power Pivot

17

17.	 If you expand the Internet Sales table in the field list, you will see a traffic light icon. 
This icon represents a KPI. KPIs are used to gauge the performance of a value. They 
are usually represented by a visual indicator to quickly determine performance.

18.	 Under the Power Pivot menu, click the Manage Data Model button.

19.	 In the Data Model Manager, select the different tabs at the bottom to switch 
between the different tables.

20.	 Go to the ProductAlternateKey column in the Product table. Notice that it’s grayed 
out. This means it’s hidden from any client tool. You can verify this by switching 
back to the Excel pivot table on sheet 1 and verifying that you cannot see the field 
in the field list.

21.	 In the Internet Sales table, click the Margin column. Notice this is a calculated 
column. It has also been formatted as currency.

22.	 Below the Sales Amount column in the Internet Sales table, there is a measure 
called Total Sales Amount. Click the measure and note that in the formula bar above 
the table is the DAX code used to calculate the measure.

23.	 On the left side of the Home tab of the Data Model Manager, switch to the diagram 
view. Observe the relationships between the tables.

24.	 If you hover over the relationship with the mouse pointer, you can see the fields 
involved in the relationship, as shown in Figure 1-17. 

Figure 1-17.  Exploring relationships


