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Dear Reader,
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Sybex books, all of which are written by outstanding authors

who combine practical experience with a gift for teaching.

Sybex was founded in 1976. More than 30 years later,

we’re still committed to producing consistently exceptional

books. With each of our titles, we’re working hard to set a

new standard for the industry. From the paper we print on,

to the authors we work with, our goal is to bring you the

best books available.

I hope you see all that reflected in these pages. I’d be very

interested to hear your comments and get your feedback on

how we’re doing. Feel free to let me know what you think

about this or any other Sybex book by sending me an email

at nedde@wiley.com. If you think you’ve found a technical

error in this book, please visit http://sybex.custhelp.com.

Customer feedback is critical to our efforts at Sybex.

Best regards,

Neil Edde

Vice President and Publisher

Sybex, an Imprint of Wiley
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Foreword

Do you really want to read a Foreword? Really? If I were you,

I’d be skipping to the chapter on creating impressive looking

surfaces, but since you’re here, I’ve got something really

important to say to you. You are living in an amazing time.

Way more amazing than the last “amazing time” someone

told you about. This is the year you are learning SolidWorks.

There’s a lot to be said about taking that on, but I’ll whittle

it down to this: You’re in for a ride.

When people go about learning a 3D modeling application

like SolidWorks there’s a hesitation that simmers in the idea

that there’s just way too much to learn. It’s true. There is

too much to learn—in one day. However, just as languages

have a set of commonly used words, so too does SolidWorks

have a set of commonly used features. Features which, after

a week of practicing using this book, will give you all the

abilities needed to introduce SolidWorks to your team, verify

a design, get a better job, or create a new idea. I imagine

one of those abilities is going to be very important for you

over the coming years. What’s even more important is how

you start gaining those abilities.

You could have started modeling 3D geometry 15 years

ago when SolidWorks first came on the scene. You actually

may have, but don’t kick yourself if you didn’t. Over those

past 15 years, developing products in 3D has changed

immensely. SolidWorks has been a big part of making that

happen. I’ve seen the program gain an enormous feature

set that has expanded from basic modeling features to

complex assembly and surface design with added

functionality for rich simulation and motion analysis. It is a

program that spans an increasing number of industries and

disciplines. With all of that it truly becomes a program

which, in the right hands, would turn a capable person like



yourself into a modeling genius. That’s the potential you

have starting right now. Plus, you’re not alone. I’ve seen the

user base grow to become one of the largest in the

mechanical design communities in the world. People from

around the world interact daily within online resources

spanning video tutorials and model data across a growing

number of web sites, blogs, and forums. If you want to

model it in SolidWorks, there’s likely someone out there

doing it.

So, you probably get the idea that there’s a lot of

information out there about SolidWorks. It can get

distracting and overwhelming. So, I want to give you a

challenge. Focus intently on this book for a week with all the

passion you can muster. Write in the margins, highlight the

text, and apply each topic to what you design. This is it

where it gets real. This is where you start to not only learn

more about how to master SolidWorks, but also how to

apply what you can do with SolidWorks daily to expanding

your career. Many times the only thing missing is the right

book. I’m convinced this book, is that book. So now, you

have a great program, a great book, and a challenge to

complete. You won’t be disappointed.

—Josh Mings

SolidSmack.com

http://solidsmack.com/


Introduction

Whether you are a new user of SolidWorks or a professional

who wants to improve your skills, this book was written for

you. Learning any software can be difficult at times. You

launch the software for the first time, and you feel

overwhelmed, not knowing how to even start a new

document. In 3D CAD programs, it can be especially

difficult. Many times a whole new vocabulary and a whole

new creative environment are introduced.

In this book, you will learn how to use the software—it

covers everything from what you see when you open

SolidWorks for the first time to 3D solid modeling and to

how to create high-resolution renderings of the desk-top

lamp that you will create by following the examples. With

plain-English step-by-step tutorials, you will create 3D parts,

assemblies, and drawings. Not only will you learn how to

create models and drawings, but you will be introduced to

some of the reasons why certain techniques are used and

how to put them to use in your daily job.

As with previous releases, SolidWorks 2010 has introduced

many new tools and commands to make your daily life

easier. You will be introduced to the new tools in parts,

assemblies, and drawings, including the new mouse gesture

support, the changes to reference planes, the Dimension

Palette in drawings, and many more. You will also learn how

to create various templates and how to customize your

workspace, all meant to increase your productivity. Although

many of the more advanced modeling techniques are not

covered in this book, any level of user will still be able to

find something new about the software.

At the end of it all, you’ll use the model of the lamp to

create photorealistic renderings using the newly updated

PhotoView 360. In 2010, PhotoView 360 was updated with



even more tools to create renderings rivaling that of

PhotoWorks. With new ways of controlling scenes, support

for background images and custom environments, and new

camera effects, you can create images that bring your

models to life. As with all the chapters in the book, you will

learn how to create your own images with step-by-step

tutorials.

What You Will Learn in This

Book

Each chapter was written to gradually introduce new tools

and concepts as the design progresses. Each subsequent

chapter will describe progressively more advanced

techniques. Specifically, the book is structured as follows:

Chapter 1 describes the SolidWorks user interface,

including the menus and toolbars, the CommandManager,

the FeatureManager design tree. You’ll also learn about

ways to improve productivity with shortcut keys and mouse

gestures.

In Chapter 2, you will learn the basics of using SolidWorks,

including the various document types, how they relate to

each other, and how parts, assemblies, and drawings are

created.

In Chapter 3, you will create your first 3D model of the

lamp base. You will learn how to create a fully defined

sketch and how to use it to create extrusions that form the

model.

In Chapter 4, using the model created in Chapter 3, you

will create a 2D drawing suitable for manufacturing using a

variety of drawing methods, including importing annotations

from the model, using the Dimension Palette to tolerance a

dimension, and creating various drawing view types.



Chapter 5 will demonstrate how to create the shaft for the

lamp base by using a revolved feature.

Chapter 6 will continue to explore the revolve command to

create a washer and washer cover for the lamp shade. Then,

after creating the two models, you will learn how to create

your first assembly, and you will be introduced to assembly

mates.

In Chapter 7, using the assembly created in Chapter 6, you

will create an assembly drawing and learn the basics of how

to use a bill of materials (BOM).

In Chapter 8, you will learn even more modeling

techniques, including how to create a swept feature, add

reference planes, and use mirrored features. You will even

learn how to create a modeled thread on the part.

Chapter 9 will show you how to create in-context models

within a subassembly when you create the lamp’s shade.

More assembly mates will then be demonstrated when you

create multiple configurations to define the shade’s

positions.

Chapter 10 will demonstrate some of the methods used to

modify existing SolidWorks documents using a variety of

techniques.

In Chapters 11 and 12, you will put everything together to

create the top-level assembly of the desk lamp. After

creating the assembly, you will learn how to add a BOM to

the environment as well as create an exploded view of the

top-level assembly to see how it all goes together.

Chapter 13 will show you how to create the final drawing

for the desk lamp project and some additional drawing

techniques meant to increase productivity.

In Chapter 14, you will learn various techniques for sharing

your model and drawings with other users, manufactures,

vendors, and sales teams.

Chapters 15 and 16 will describe the process for creating

your own templates in SolidWorks.



Chapter 17 will introduce you to PhotoView 360 and will

show you how to create photorealistic renderings of the

desk lamp using new enhancements in the rendering

software.

At the end of the book is a glossary of terms that are used

in the book and that are related to SolidWorks and

mechanical design, followed by an index.

Files on the Website

A few exercises in this book require additional files such as

templates, tables, and some models not created in the

exercise. The entire project including each part, assembly,

and drawing is also available for download. You can

download the accompanying files from this book’s page on

Sybex’s website at www.sybex.com/go/solidworks2010ner. Click

the Downloads button on that page to access the files. You

can also find the same files as well as additional content,

forums, and more examples at www.swner.com.

How to Contact the Author

I welcome feedback from you about this book or about

books you’d like to see from me in the future. You can reach

me by writing to alexruiz@theswgeek.com. For more

information about my work, please visit my website at

www.theswgeek.com.

Sybex strives to keep you supplied with the latest tools

and information you need for your work. Please check its

website at www.sybex.com, where we’ll post additional content

and updates that supplement this book if the need arises.

Enter SolidWorks in the Search box (or type the book’s

ISBN—9780470505434), and click Go to get to the book’s

update page.

http://www.sybex.com/go/solidworks2010ner
http://www.swner.com/
mailto:alexruiz@theswgeek.com
http://www.theswgeek.com/
http://www.sybex.com/


Chapter 1: Becoming Familiar

with SolidWorks

Start SolidWorks

Navigate the SolidWorks Interface

Use the CommandManager

Use and Customize the Menus

Use Toolbars

Use the Keyboard

Use the Mouse

SolidWorks 2010 is one of the most popular 3D mechanical

computer-aided design (CAD) packages on the market

today. Since its introduction in 1995, SolidWorks has become

a favorite design tool for many of today’s engineers,

mechanical designers, and industrial designers. In part

because of its easy-to-learn graphical user interface and

powerful set of tools, SolidWorks is used by many top

companies worldwide to design, engineer, and document

their products in a variety of fields.

At the core of SolidWorks is the ability to create parametric

3D solid geometry that is then used to create drawings,

manufacturing instructions, instruction manuals,

animations, full-color renderings, and other types of

documentation. Regardless of the complexity of the item

being created, the creation process is easy and follows the

same basic steps. First a sketch is created that is turned into

a base feature. The base feature is then further refined by

adding features that add or remove material from the base

feature. Individual part models can then be used to build

assemblies that represent the final design. After creating the

3D part or assembly models, drawings are made to

document the design and manufacturing process.



Learning a new CAD package can be a daunting task. In

addition to the new terminology, first-time users may feel a

bit overwhelmed with a new user interface, toolbars, and

commands. In this chapter, you will spend some time

launching SolidWorks for the first time, becoming familiar

with the SolidWorks interface, and working with the

CommandManager.

Start SolidWorks

Before installing and running SolidWorks for the first time,

ensure that you meet the recommended minimum system

requirements. SolidWorks currently supports the following

operating systems:

Windows 7 (32-bit) Professional, Ultimate or Enterprise

Edition.

Windows 7 (64-bit) Professional, Ultimate or Enterprise

Edition.

Windows Vista (64-bit) Ultimate, Business, or Enterprise

edition, SP0 or newer

Windows Vista (32-bit) Ultimate, Business, or Enterprise

edition, SP0 or newer

Windows XP Professional (32-bit), SP2 or newer

Windows XP Professional (64-bit)

And here are the random-access memory (RAM)

requirements:

Minimum 1GB RAM when parts contain fewer than 200

features and assemblies contain fewer than 1,000

components

Recommended 2GB RAM or more when parts contain

more than 200 features and assemblies contain more than

1,000 components

Once you have verified that your computer is able to

support SolidWorks and it is installed onto your system, you



can launch it by selecting Start  ⇒ Programs  ⇒ SolidWorks

2010 ⇒ SolidWorks 2010 SPX.X ⇒ SolidWorks 2010.

NOTE All images in this book are from SolidWorks running on

Windows 7. You might notice a slight difference if you are using

another version of windows such as Windows XP.

SolidWorks License Agreement

The first time you launch SolidWorks, you will be presented

with the SolidWorks License Agreement. You must accept

the license agreement in order to use SolidWorks. After

reading the license, click Accept to continue.If for some

reason you do not accept the terms of the license

agreement, clicking Do Not Accept will exit SolidWorks.

Help and Workflow Customization

After accepting the SolidWorks License Agreement, you will

then be presented with the Welcome To SolidWorks window.

This screen allows you to customize the appearance of

dynamic help as well as the workflow. You will see this only

the first time you launch SolidWorks on your computer, but

you can make changes to the options anytime you want in

the SolidWorks Options window.

Three options are available in the Help Customization

section of the screen. Each option will provide the user with

a different level of dynamic help, so consider your needs

when making your selection.

I Am A New User. Show Quick Tips To Help Me Get

Started. This option will provide you with pop-up

messages that appear while working in different modes of

SolidWorks.



I Am New To This Version Of SolidWorks. Show Me

Interactive What’s New Help. Experienced SolidWorks

users will find this option helpful when they are working in

a new version of SolidWorks. When this option is selected,

a question-mark icon will be displayed on new menu items

and new and changed PropertyManagers and will link to

the corresponding sections of the What’s New manual. The

topics in the What’s New manual will then provide more

information about the new or updated functionality since

the previous release.

Do Not Show Me Any Dynamic Help. For more

experienced users, this option will not provide you with

any pop-ups or links to the What’s New manual while

working in SolidWorks.

NOTE As you become more familiar with working in SolidWorks,

you may decide to disable the Quick Tips. You can disable them

by selecting Help ⇒ Quick Tips or by clicking the question-mark

icon in the status bar. After becoming familiar with the updates

made to the new release of SolidWorks, you can disable the

display of the link by selecting Help ⇒ Interactive What’s New.

The Workflow Customization section of the Welcome To

SolidWorks window allows you to hide and display tools,

links, and menus items based on your usage of SolidWorks.

You can select one, two, all, or none of the following

categories:

Machine Design

Mold Design

Consumer Product Design

When you select an option in the Workflow Customization

section of the window, the following changes will occur in

your part document environment:

Machine Design The Machine Design Overview, Machine

Design Tutorials, and SolidWorks SimulationXpress links



will be displayed on the SolidWorks Resources tab of the

task pane. Sheet Metal and Weldments tabs will be added

to the CommandManager. The Molds menu item will be

hidden in the Insert menu. Draft Analysis, Undercut

Detection, and Deviation Analysis will also be hidden in the

Tools menu.

Mold Design The Mold Design Overview, Mold Design

Tutorials, and Import File links will be displayed on the

SolidWorks Resource tab of the task pane. Surfaces and

Molds tabs will be added to the CommandManager. The

Weldments menu item will be hidden in the Insert menu.

Consumer Product Design A Consumer Product Tutorials

link will be displayed on the SolidWorks Resources tab of

the task pane. The Surfaces tab will be added to the

CommandManager. The Weldments menu item will be

hidden in the Insert menu. The Undercut Detection menu

item will be hidden in the Tools menu.

NOTE You can adjust your workflow customization at any time

while in a part file by selecting Tools ⇒ Customize and select the

Options tab. In the Work flow Customization section, select or

deselect the appropriate options.

For the sake of the project being demonstrated in this

book, in the Welcome To SolidWorks window select the

following:

1. In the Help Customization section, select Do Not Show

Me Any Dynamic Help.



2. In the Work flow Customization section, select Consumer

Product Design, Machine Design, and Mold Design.

3. Click OK.

Navigate the SolidWorks

Interface

Before using SolidWorks, you should become familiar with

the layout of the user interface. Each of the three document

types in SolidWorks (parts, assemblies, and drawings) has

the same basic interface with a few minor differences. To

start, we will examine the common elements of the three

document types. Figure 1-1 shows the SolidWorks interface

when you have a part model open.

Graphics Area

The place where all the action takes place in SolidWorks is

the graphics area. Here you will be modeling your parts,

putting together your assemblies, and creating your

drawings. You will be exploring this area in a lot more detail

in Chapter 2, “Learning the Basics,” when we cover the

three document types in more detail.

Figure 1-1: SolidWorks 2010 user interface



Heads-up View Toolbar

At the top of the graphics area is the Heads-up View toolbar.

This transparent toolbar is always available at the top of

your graphics area, giving you quick and easy access to the

tools necessary to manipulate your views. Icons that display

a small downward-pointing arrow provide you with more

tools in a flyout, as shown in Figure 1-2.

Figure 1-2: Flyout menu showing additional tools

As you become more comfortable in SolidWorks, you may

discover that the tools available on the Heads-up View

toolbar may not be what you use most often. The view tools

shown by default are not the only tools that are available for


