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Introduction

So you want to learn image editing!
Maybe you’ve been shooting lots of pictures with your digital camera and want to learn

how to make them look great, or prepare them for the web.
Maybe you’re interested in creating drawings or cartoons. Or you’re already editing pho-

tos, but you want to do more… even learn some of the theory behind imaging.
In any case, you’ve been hearing about GIMP—the GNU Image Manipulation Program—

and you’re ready to learn how to use it and get the most out of it.
This book is ideal for anyone attempting image editing for the first time, but it goes deep

enough to satisfy the intermediate GIMPster who knows the basics but needs more. Plus, it
contains enough tricks and reference matter to gratify even power users. Anyone with an
interest in digital art and a willingness to explore should find lots of useful tips and fun proj-
ects throughout the book.

This second edition includes several new projects and tips not in the first edition, and
covers some of the new features that went into 2.4 at the last minute (as well as a preview of
GIMP 2.6).

Structure of the Book
The first few chapters assume no knowledge at all of GIMP or of any other image-editing pro-
gram. Later chapters will assume you’ve picked up these basics, and will build on them.

Chapter 1 introduces GIMP’s various windows, menus, and interface conventions. GIMP
has a somewhat different user interface from most other programs, so it helps to get an idea of
how its windows and dialog boxes work together and how the menus are structured.

Beginning with Chapter 2, you’ll dive into practical image-editing tasks. Chapters 2
through 6 each cover a different category of image operations—layers, drawing, selection,
touching up—and each one describes a series of different and related techniques.

Chapter 7 takes you on a whirlwind tour of the special effects available in GIMP. Then
you’ll dive into more advanced topics in Chapters 8 through 10, which cover subjects such as
color theory, layer mode effects, shading, perspective, image stacking, and panoramas.

Chapter 11 explores scripts and plug-ins: how they work, how to install existing ones, and
how to take one and tweak it to do something slightly different. I hope that even people with
no programming experience will at least take a look at the scripting sections—there’s a lot you
can do with GIMP scripts, even if you’ve never written a line of code before.

For the exercises throughout most of the book, you will want to have some digital photo-
graphs handy. If you don’t already have a digital camera or a collection of scanned photos,
the section “Additional Resources” in Chapter 12 offers a list of websites where you’ll find all
sorts of terrific photos you can use in your own projects. The rest of Chapter 12 covers a few
topics that don’t fit anywhere else in the book, plus web resources for finding more GIMP
information.

xxv



If you don’t already have GIMP installed on your computer, skip straight to Appendix A for
an outline of how to install GIMP on the most common platforms it supports—Windows, Mac
OS X, and Linux. Appendix B gives tips on installing on older versions of those operating sys-
tems. If you ever decide you want to build GIMP from source, Appendix C has tips on how to
do just that. Finally, Appendix D gives a look at the upcoming GIMP 2.6.

A Note on GIMP Versions
This book was written based on GIMP 2.4. As it goes to press, the development version, 2.5, is
coming along and there’s no telling when it will be released as 2.6.

Therefore, I’ve tried to include enough 2.5 information, where it differs from 2.4, that the
book will be useful with 2.6. Appendix D gives an overview of the differences. You can also use
the book with an older 2.2 or even 2.0 GIMP version, though you’ll miss some of the nice new
features introduced with 2.4. When possible, I mention locations of menu items that have
moved.

If you’re using Beginning GIMP with GIMP 2.6, check the book’s website, http://gimpbook.
com, for notes on any features that may have changed after the book went to press.

Downloads and Feedback
When learning image editing, it’s always helpful to have lots of examples you can use. Some of
the images that appear in the book are available in GIMP’s native XCF format on the Apress
website, along with any scripts used to create them. You’ll also find source code there for the
scripts and plug-ins presented in Chapter 11, a collection of the images used in the book, and
any (gasp!) errata. Just point your browser to www.apress.com and search for this book.

I also maintain a website for the book at http://gimpbook.com, with a separate errata page,
the images used in the book, and an updated version of the links from Chapter 12.

Please email any feedback or suggestions to akkana@gimpbook.com.
I hope you enjoy your introduction to GIMP!
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Getting to Know GIMP

Welcome to the GNU Image Manipulation Program—more commonly known as GIMP.
GIMP is the premiere open source image-editing program. It’s powerful and fun to

use…but it’s also easy to get lost in when you’re just starting out. This chapter will introduce
you to the program, and offer some tips on how to get the most out of GIMP.

You’ll become familiar with GIMP’s interface—its most important windows, dialogs, and
menus, plus some handy tricks and shortcuts. If you’ve already used GIMP a bit, a lot of the
chapter may be review, but you may find some helpful tips you haven’t seen before.

Along the way, I’ll cover

• What is GIMP?

• A tour of important GIMP windows

• Menu overview

• Some GIMP settings you can customize (and why you might want to)

• A first GIMP project

What Is GIMP?
GIMP, sometimes called the GIMP, is the GNU Image Manipulation Program.

It’s a computer program for creating and editing digital images. In particular, it’s designed
for editing digital photographs and typical web graphics. You can also use it to make some
pretty amazing drawings.

GIMP is a complex program suitable for professional artwork, but it’s also just plain fun—
a place to play with pretty pictures and let your imagination run wild. As you read this book,
please keep that in mind. Make a point of “fooling around” and having fun with your image-
editing projects.

GIMP is also free open source software. It’s written and maintained by volunteers and dis-
tributed without cost. In fact, you’re encouraged to make copies of it to share with friends, and
you can even contribute to it yourself.

GIMP arose out of a 1995 computer science class project by Spencer Kimball and Peter
Mattis. Within a year, it had grown into a popular open source image editor, with users and
contributors from around the world. It’s been growing and improving ever since.
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Today, GIMP is used by countless people worldwide. It runs on most Windows systems,
Mac OS X, Linux, and most versions of UNIX, as well as a few more obscure systems. The pro-
gram is free software in both senses of the word “free”: you don’t have to pay anything to use it,
and GIMP’s inner workings (“source code”) are available for anyone to examine, contribute to,
distribute, or learn from. The latest is always available from http://www.gimp.org.

GIMP stands as a shining example of the power of free, open source software. It’s written
and maintained by volunteers who keep in touch by means of internet relay chat (IRC) and
mailing lists, despite time zone and language differences. GIMP users who want to get more
involved can participate in the GIMP project’s mailing lists, contribute bug fixes or new fea-
tures, design new brushes or patterns, or write their own plug-ins and scripts to share with the
world. Or they can just enter goofy photo contests to show what cool things can be done with
GIMP!

A note about terminology: you’ll often see GIMP referred to as the GIMP. “The GIMP” was
the program’s official name until the 2.4 release, when the name was officially changed to just
“GIMP.” You’ll still see lots of references to “the GIMP” in tutorials and other articles (and even,
sometimes, on the gimp.org website). In the second edition of Beginning GIMP I’ll mostly
avoid the “the” and call it just plain GIMP, but I hope you’ll bear with me if I slip from time
to time.

A Tour of the Most Important GIMP Windows
One of the first things you’ll probably notice about GIMP is that it likes to use lots of windows.
Instead of having one big window that contains the various images you’re using, the GIMP
model lets you control your toolbox, layer controls, and each image separately. You can choose
which windows are visible at any given time.

The main windows you need to know about are the Toolbox with its Tool Options, image
windows (one for each image you have open), and the Layers dialog.

The Toolbox
The Toolbox window (Figure 1-1) is GIMP’s main window. It appears when you run GIMP
without any images, and closing it exits the GIMP application. It has a menu bar where you
can find GIMP functions that aren’t tied to any particular image (though in GIMP 2.6, the Tool-
box no longer has a menu and these functions will move to the image window menus—see
Appendix D for more details). It also has a collection of tool buttons and a couple of helpful
controls.
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Figure 1-1. The Toolbox window
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The tool buttons are the heart of the Toolbox window. GIMP has tools for selection (like
Rectangular Select, the first tool in the Toolbox), tools for painting (like the Paintbrush, the
tool that’s active in Figure 1-1), and tools for changing images in a variety of ways. GIMP
always has one active tool; if the active tool corresponds to one of the tool buttons, that 
button will appear “pressed,” as with the Paintbrush tool in Figure 1-1.

You can resize the Toolbox to taste, and the tool buttons will adjust their positions. As
GIMP comes out with new versions, the tool buttons sometimes change position, so it’s best
not to rely on a button being in any particular place. Each tool has a tooltip to help you
remember its function, which you can see by hovering your mouse over a button and pausing
for a second or two.

There are a couple of other ways to activate a GIMP tool besides clicking a Toolbox but-
ton. There’s the Tools dialog, accessed from the Toolbox as File ➤ Dialogs ➤ Tools or from any
image window as Dialogs ➤ Tools. It lists every tool GIMP has (not all of them are in the Tool-
box). You can control which tools show up as buttons in the Toolbox by clicking the “eye” icon
next to each tool in the Tools dialog, and you can change their order by dragging tools to a dif-
ferent place within the dialog.

You can also activate tools through the Tools top-level menu in every image window.
Finally, most tools also have a keyboard shortcut associated with them; these shortcuts are
listed in the image window’s Tools menu.

Below the tool buttons, the Toolbox shows two color “swatches,” initially black and white.
These represent GIMP’s current foreground and background colors, used in all sorts of opera-
tions. Clicking on either swatch brings up a color chooser. You’ll use the color swatches a lot in
Chapters 3 and 4.

■Tip GIMP supports drag-and-drop in many places throughout the application. You can open images by
dragging them from your desktop or file manager window to the GIMP Toolbox—just drop the image on top
of the buttons. (Unfortunately, this doesn’t currently work on Mac OS X due to limitations in Apple’s X11
package.)

You can configure GIMP to show some other useful selectors next to the color swatches;
see the section “A Few GIMP Settings You Can Customize,” later in this chapter, to learn which
settings you can customize.

Tool Options
Below the color swatches is typically an area called Tool Options, which shows settings affect-
ing the operation of the active tool. In Figure 1-1, the active tool is the Paintbrush, so the
options showing are the ones for that tool. You can make Tool Options a separate dialog if you
like (see the section “The Layers Dialog and Dialog Docking”), but most people prefer to leave
it in its standard position, docked underneath the Toolbox. The buttons at the bottom of the
dialog let you save or restore settings for the tool, or reset the options to their default values.
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Image Windows
A toolbox is fine, but an image-editing program isn’t any fun without images! GIMP uses a sep-
arate window for each image you open. That way, you can have big windows for big images,
and small windows for small ones.

A fun and easy way to create an image window is to run one of the Logo scripts. There are
lots of them (you’ll see a complete list in Chapter 7), but for now, you just need one. Go to the
Toolbox’s Xtns menu (in GIMP 2.6, look under File ➤ New) and click Xtns ➤ Logos ➤ Cool
Metal. In the dialog that opens, you can change the Text to anything you want…or you can
leave it at the default, “Cool Metal.” Click OK, and you have a new image window (Figure 1-2).

Figure 1-2. An image window

Let’s start at the top. The image window’s title bar gives information about the image: its
file name and “view number,” whether it’s in full color (denoted RGB, for Red, Green, and
Blue), the number of layers, and the current size of the image in pixels. You can change the
information GIMP shows here; see the “GIMP Preferences” section in Chapter 12.

The window also has a menu bar, which offers a collection of operations for working on
the image. You can hide the menu bar to offer more space for the image (Preferences again);
in that case, use the menu button at the upper left of the window to show the menu, or right-
click on the image to open the context menu.

The rulers at the top and left sides of the image window show the position of your mouse
in the image. You can also use the rulers to set up “guides,” gridlines on the image to help you
draw exactly where you want (you’ll meet guides in Chapter 4).
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Moving down to the bottom-left corner, the QuickMask button helps with defining selec-
tions. See Chapter 5 for details.

The location area below the QuickMask button gives a precise readout of the current
mouse position if your mouse is in the window (otherwise it’s blank); the menu button next to
it lets you display the mouse position in any unit you find most comfortable, such as pixels,
inches, or points (most of the time, I recommend sticking with pixels).

The scale menu, or zoom control, shows whether the image is currently being displayed
at actual size (100%), shrunk to a smaller size, or magnified to a larger size. There are lots of
other ways to zoom, too. You can use the View ➤ Zoom menu, or use the + and – keys to zoom
in or out. You can activate the Zoom tool (in the Toolbox, click on the tool button that looks
like a magnifying glass), then click in the image to zoom in (Ctrl+click to zoom out). If you
have a mouse with a scroll wheel, you can also zoom by using the Ctrl key in combination
with the mouse wheel. Finally, if you click on the resize toggle in the upper-right corner of the
image window, you can resize the image window and the image will automatically zoom to fit
the new window size.

The status bar along the bottom of the window shows more information about the image:
specifically, which layer is selected and how much memory the image is using. It also shows a
progress bar when GIMP is performing a time-consuming operation, with a Cancel button
right next to it.

The navigation control at the bottom right lets you “pan” around the image instead of
using the scrollbars (click on it to see how it works). For images that are too big to fit on the
screen, panning can be quicker than scrolling. You can also pan by dragging anywhere in the
image window while holding down the middle mouse button, or by holding down the space-
bar while dragging in the image with the left button. (You can configure the spacebar to call
up the Move tool rather than panning: see the section “A Few GIMP Settings You Can Cus-
tomize,” later in this chapter).

The Layers Dialog and Dialog Docking
GIMP has a lot of useful dialogs—you can see the whole list from File ➤ Dialogs in the Toolbox
menu or the image window’s top-level Dialogs menu—and it lets you configure which dialogs
will be grouped together using a mechanism called docking.

Each separate dialog window is called a dock, and can hold quite a few dialogs inside it.
Aside from the Toolbox, GIMP 2.4 initially makes one dock visible (Figure 1-3).
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Figure 1-3. The Layers (top) and Color (bottom) dialogs docked together, along with many other
dialogs also docked (see the tabs above “Layers” and above “FG/BG Color”)

Initially you can see two dialogs in this dock: the Layers dialog (the top half) and the
FG/BG Color dialog (the bottom). But there are many more dialogs docked here, visible only
through tabs. The Layers half of the dock also includes tabs for Channels, Paths, and History
(Undo), while the Color half includes tabs for the Brush, Patterns, and Gradients dialogs. Select
any tab to make that dialog visible.

But you’re not stuck with this layout: you can group dialogs together any way you like,
using docking (Figure 1-4). Press and hold the left mouse button in the drag handle area—the
title area or tab, highlighted as “Drag from” in Figure 1-4—and drag to where you want the dia-
log to be. You can drag to the drag handle or tab area of another dock, and the dialog will be
added as a new tab; or you can drag to the docking bar at the bottom of an existing dock to
create a new dialog area below what’s already there. Take care to drop exactly where you want
the dialog to end up: if you drop between two tabs of an existing dock, that’s where the
dragged dialog’s tab will end up.
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Figure 1-4. Drag handles and docking bars in the Toolbox and a dock window

You can also drag a dialog to your desktop, which gives you a new dock window contain-
ing only that dialog. Finally, from the Toolbox File ➤ Dialogs or the image window Dialogs
menu, you can choose Create a New Dock, which offers a few popular combinations like
Layers, Channels & Paths (which, confusingly, will also include Undo).
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■Caution When you close a dock containing several dialogs, GIMP 2.4 will forget how they were docked—
even if it was just GIMP’s default initial configuration. There are two ways to get the default configuration
back: you can build them up from the combinations in File ➤ Dialogs ➤ Create a New Dock; or you can
exit GIMP, remove your GIMP profile, and start over. GIMP 2.6 will offer a solution: Windows ➤ Recently
Closed Docks.

I’ll refer to dialogs by their individual names throughout this book. In particular, you’ll be
using the Layers dialog quite a lot starting with Chapter 3, and I’ll just call it the Layers dialog—
it doesn’t matter whether you keep it by itself or docked with seven other dialogs.

Menu Overview
You’ll learn all about the functions in GIMP’s menus as you explore later chapters, but here’s a
quick tour of which menu does what.

The Toolbox menu bar offers operations that don’t apply to a specific image. This includes
File operations such as New and Open, the Dialogs menu, a Help menu for online help, and a
menu labeled Xtns (short for “Extensions”).

Of particular interest is the Xtns menu. This menu gives you access to a menagerie of
extensions that can create new images. Included are submenus offering a collection of scripts
to create various styles of text logos, buttons (for use on web pages), shapes such as a sphere,
interesting patterns and brushes, and themes you can use for web pages.

The Xtns menu also contains GIMP’s Plug-in Browser. Many of GIMP’s functions are
implemented as plug-ins, and it can sometimes be difficult to find a specific function in the
menus. The Plug-in Browser lets you search for plug-ins by name, and then tells you where in
the menus you can find them. See Chapter 11 for more details.

■Note Don’t get too attached to the Toolbox menus. In GIMP 2.6, the Toolbox will no longer have a menu
bar, and all those functions will move to image window menus. This will include a new top-level Windows
menu you can use to access any dialog or any currently open image—it also includes a helpful Recently
Closed Docks category—and a menu under File ➤ New that replaces the new image-creation operations in
the Xtns menu.

The Toolbox menus also offer another very handy feature: tear-offs.

Tear-off Menus and Context Menus
GIMP has a lot of features, and exploring can get frustrating when you want to try out lots of
different options that are buried in the same deep menu. Tear-offs can help: they let you grab
any menu and turn it into a window of its own.
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For instance, suppose you want to explore GIMP’s long list of Logo scripts, available from
the Toolbox’s Xtns ➤ Logos submenu (Figure 1-5). You’d have to keep clicking on Xtns, then
click or drag to Logos, then choose the item you want to try next. But click on the Logos tear-
off, and the submenu detaches and becomes a new window on your desktop, where you can
keep it as long as you like.

Figure 1-5. Tearing off a menu makes it appear as a new window.
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