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Introduction

So you want to learn image editing!
Maybe you’ve been shooting lots of pictures with your digital camera and want to learn

how to make them look great, or prepare them for the web.
Maybe you're interested in creating drawings or cartoons. Or you’re already editing images,

but you want to get better . . . even learn some of the theory behind imaging.
In any case, you’ve been hearing about the GIMP—the GNU Image Manipulation Program—

and you’re ready to learn how to use it and get the most out of it.
This book is ideal for anyone attempting image editing for the first time, but it goes deep

enough to satisfy the intermediate GIMPster who knows the basics but needs more. Plus, it
contains enough hidden tricks and reference matter to gratify even power users. Anyone with
an interest in digital art and a willingness to explore should find lots of useful tips and fun projects
throughout the book.

Structure of the Book
The first few chapters assume no knowledge at all of the GIMP or of any other image editing
program. Later chapters will assume you’ve picked up these basics, and will build on them.

Chapter 1 introduces the GIMP’s various windows, menus, and interface conventions.
GIMP has a somewhat different user interface from most other programs, so it helps to get an
idea of how its windows and dialog boxes work together and how the menus are structured.

Beginning with Chapter 2, you’ll dive into practical image editing tasks. Chapters 2 through 6
each cover a different category of image operations—layers, drawing, selection, touching up—
and each one describes a series of different and related techniques.

Chapter 7 takes you on a whirlwind tour of the special effects available in the GIMP. Then
you’ll dive into more advanced topics in Chapters 8 through 10, which cover subjects such as
color theory, layer mode effects, shading, perspective, image stacking, and panoramas.

Chapter 11 explores scripts and plug-ins: how they work, how to install existing ones, and
how to take one and tweak it to do something slightly different. I hope that even people with no
programming experience will at least take a look at the scripting sections; there’s a lot you can
do with GIMP scripts, even if you’ve never written a line of code before.

For the exercises throughout most of the book, you will want to have some digital photo-
graphs handy. If you don’t already have a digital camera or a collection of scanned photographs,
“Additional Resources” in Chapter 12 offers a list of places on the web to find all sorts of terrific
photos you can use in your own projects. The rest of Chapter 12 covers a few topics that don’t
fit anywhere else in the book, plus web resources for finding more GIMP information.



If you don’t already have the GIMP installed on your computer, begin by skipping ahead
to Appendix A for an outline of how to install the GIMP on the most common platforms it sup-
ports—Windows, Mac OS X, and Linux. If you ever decide you want to build the GIMP from
source, Appendix F has tips on how to do just that.

A Note on Versions
This book was written based on GIMP 2.3 development builds, slated to become the next stable
release, 2.4. However, it’s intended to be useful with GIMP versions 2.2 and 2.0 as well.

Some features have changed during the development of 2.3, and some of the menus were
restructured to group items in a more logical way. When possible, I mention locations of menu
items in the older GIMP 2.0/2.2 menu structure as well as their new location in GIMP 2.4.

A few features, such as the SIOX selection tool, are new for 2.4. Users of 2.2 can skip those
sections, or try installing the latest GIMP in order to try them out. Rest assured that even if you
don’t have those features yet, you will eventually!

Downloads and Feedback
When learning image editing, it’s always helpful to have lots of examples to work with. Some
of the images that appear in the book are available in the GIMP’s native XCF format on the
Apress web site, along with any scripts used to create them. You’ll also find source code there
for the scripts and plug-ins presented in Chapter 11, along with any (gasp!) errata. Just point
your browser to www.apress.com and search for this book.

Please email any feedback or suggestions to akkana@gimpbook.com.
I hope you enjoy your introduction to the GIMP!
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Get to Know the GIMP

Welcome to the GIMP, the premiere open source image-editing program!
This chapter will introduce you to the GIMP’s most important windows, menus, and set-

tings, and will offer some tips along the way. I’ll cover the following topics:

• What is the GIMP?

• A tour of the important GIMP windows and menus

• Some GIMP settings you can customize, and why you might want to

• A first GIMP project

At the end of this chapter, you’ll get a chance to try a simple project: combining two
images into one.

What Is the GIMP?
The GNU Image Manipulation Program, more commonly known as the GIMP, is a program for
creating and editing bitmapped images. That means it’s well suited for editing digital photo-
graphs and typical web graphics. You can also use it to make some pretty amazing drawings.

The GIMP is a complex program suitable for professional artwork, but it’s also just plain
fun—a place to play with pretty pictures and let your imagination run wild. As you read this
book, please keep that in mind. Make a point of “fooling around” and having fun with your
image-editing projects.

The GIMP arose out of a 1995 computer science class project by Spencer Kimball and
Peter Mattis. Within a year, it had grown into a popular open source project, with users and
contributors from around the world. 

Today, the GIMP is used by countless people worldwide. It runs on most Windows systems,
Mac OS X, Linux, and most versions of UNIX. The program is free software in both senses of the
word “free”: you don’t have to pay anything to use it, and the GIMP’s inner workings, or “source
code,” are available for anyone to examine, contribute to, distribute, or learn from. The latest is
always available from http://www.gimp.org.

The GIMP stands as a shining example of the power of free, open source software. It’s
written and maintained by volunteers who keep in touch by means of internet relay chat (IRC)
and mailing lists, despite time zone and language differences. Users of the GIMP who want to
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Figure 1-1. The GIMP Toolbox

get more involved can participate in the GIMP’s mailing lists, contribute bug fixes or new fea-
tures, design new brushes or patterns, or write their own plug-ins and scripts to share with the
world. Or they can just enter goofy photo contests to show what cool things can be done with
the GIMP!

■Note The GIMP is constantly evolving. The screenshots in this book are based on an early version of
GIMP 2.4, though most of the information here applies to any version of the GIMP from 2.0 on.

A Tour of the Important GIMP Windows and Menus
The GIMP normally enables you to keep several windows open at once, rather than having all
its functions available from one window. This gives you control over where the various windows
are positioned and which ones remain visible.

The following sections describe some of the most important windows GIMP uses: the
Toolbox window (and its sibling, the Tool Options dialog), the Layers dialog, and the image
windows.

The Toolbox Window
The Toolbox is the GIMP’s main window. No matter how many images you have open at once,
you’ll only have one Toolbox. In its most basic form, it looks like Figure 1-1.

The Toolbox window has four parts: a menu bar, the Toolbox buttons, the color swatches,
and buttons for the current brush, pattern, and gradient.

You can resize the Toolbox to any size you like, and the tool buttons will adjust their posi-
tions. As new versions of the GIMP are released, the tool buttons sometimes change position,
so it’s best not to rely on a tool being in any particular place in the Toolbox.
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The menu bar offers operations that don’t apply to a currently open image. This includes
File operations such as New and Open, a Help menu for online help, and a menu labeled Xtns.

Of particular interest is the Xtns menu. This menu gives you access to a menagerie of
extensions that can create new images. Inside are submenus offering a collection of scripts
that create many different styles of buttons (for use on web pages), text logos, shapes such as
a sphere, interesting patterns and brushes, and themes you can use for web pages. Take a few
moments to explore some of these functions. You can accomplish quite a bit right here, with-
out knowing any more of the GIMP.

The Xtns menu also contains the GIMP’s Plug-in Browser. Many of the GIMP’s functions
are implemented as plug-ins, and it can sometimes be difficult to find just what you’re looking
for in the menus. The Plug-in Browser lets you search for plug-ins by name, and then tells you
where in the menus to look for them. See Chapter 11 for more details.

The Toolbox buttons, occupying the central part of the Toolbox window, represent tools
for drawing, changing, and modifying images. The tools are specific to various functions such
as drawing, handling text, or moving objects. You’ll learn more about them in Chapters 2, 3,
and 4. Each tool has a tooltip to help you remember its function, which you can see by moving
your mouse over each button and pausing for a second or two.

The GIMP’s tools are also accessible through the Tools menu in the image window, and
most tools have an associated keyboard shortcut, which you can learn by looking for the tool
in the Tools menu. In addition, there’s a Tools dialog, accessed via Dialogs ➤ Tools from any
image window, or File ➤ Dialogs ➤ Tools from the Toolbox.

■Tip Not only can you access the GIMP’s tools from the Tools dialog, but also you can add or delete tools
from the buttons shown in the Toolbox by clicking on the “eyeball” icon next to each tool in the Tools dialog.
You can also change the order of the Toolbox buttons by dragging and dropping the tools within the dialog.

The color swatches allow you to change the foreground and background colors used by
the GIMP’s drawing and text tools. Initially they’re black and white, but clicking on one of the
swatches brings up a color chooser that allows you to select any color. This will be explained
further in Chapters 3 and 4.

The brush, pattern, and gradient are used for drawing; these will be discussed in more
detail in Chapter 4.

The Layers Dialog
In addition to the Toolbox window, the GIMP brings up a dialog window labeled “Layers,
Channels, Paths” (Figure 1-2). For simplicity, I’ll refer to this as the Layers dialog.

Your first instinct upon seeing the Layers dialog may be to wonder what it is and close it.
Don’t! You’ll be using layers quite soon (Chapter 3), and they’re incredibly useful for all sorts of
image operations. If you do close the Layers dialog and want to get it back, you can find it in
the File ➤ Dialogs submenu in the Toolbox window, along with a collection of other dialogs
the GIMP offers.



Figure 1-2. The Layers dialog

■Note The GIMP has quite a few dialogs in addition to the Layers dialog, and these can be grouped
together. You can see a list of them in the File ➤ Dialogs submenu of the Toolbox window. See the section
“Grouping Dialogs by Docking” later in this chapter.

The Tool Options Dialog
Each tool in the Toolbox has options associated with it. These options are collected in a dialog
called Tool Options.

The Tool Options dialog is normally docked just below the Toolbox (Figure 1-3), although
you can split it off into a separate dialog if you prefer. (See later in this chapter for an explana-
tion of docking under “Grouping Dialogs by Docking.”) The dialog isn’t titled “Tool Options”;
instead, the title reflects the current tool, in this case, “Rect Select.” When you choose a new tool
in the Toolbox, the contents of the Tool Options dialog immediately change to reflect options
that apply to the new tool. If you prefer to use Tool Options as a separate dialog, double-clicking
any tool in the Toolbox will bring up its Tool Options dialog.

Some tools have quite a few options. If there are too many options to fit in the window
size you’ve chosen, a scrollbar will appear. The most common options are usually listed first,
so most of the time you won’t need to scroll to see the options you need.

CHAPTER 1 ■ GET TO KNOW THE GIMP4



Figure 1-3. Tool Options for Rect Select
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Image Windows
An image-editing program isn’t any fun without images. In the GIMP, every image has its own
window (Figure 1-4).

Let’s start at the top. The image window’s title bar gives information about the image: its
file name and internal GIMP identification number, whether or not it’s in full color (denoted
RGB, for red, green, and blue), the number of layers, and the current size of the image. You can
change the information in the GIMP’s title bar; see the section “Image Windows: Title and
Status” later in this chapter for more information.



The window also has a menu bar, which offers a selection of operations for working on
the image. You can hide the menu bar to offer more space for the image (via Preferences); in
that case, use the menu button at the upper-left corner of the window to show the menu, or
click the right mouse button on the image.

The rulers at the top and left side of the image window show the position of your mouse
in the image. You can also use the rulers to set up guides, or grid lines on the image to help
you draw exactly where you want (you’ll meet guides in Chapter 4).

The QuickMask button helps with defining selections. See Chapter 5 for a detailed discus-
sion of how to use the quick mask.

The location area in the lower-left corner gives a precise readout of the current mouse
position if your mouse is in the window (otherwise it’s blank). The menu button next to it lets
you show the mouse position in any unit you find most comfortable, such as pixels, inches, or
points.

The scale menu shows whether the image is currently being displayed at actual size (100%),
shrunk to a smaller size, or magnified to a larger size. You can change the magnification
with this menu, via the View ➤ Zoom menu, or by using the + and – keys. If you have a mouse
with a scroll wheel, you can also zoom by using the Control key in combination with the
mouse wheel.

The status bar shows more information about the image: specifically, which layer is
selected and how much memory the image is using. The Cancel button next to the status bar
becomes active when the GIMP is in the midst of a time-consuming operation.

CHAPTER 1 ■ GET TO KNOW THE GIMP6

Figure 1-4. An image window



Figure 1-5. Context menus
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The navigation control in the lower-right corner lets you pan around the image instead of
using the scrollbars. For large images that don’t fit on the screen, panning can be quicker. You
can also pan by dragging in the image window while holding down the middle mouse button.

The zoom control toggles whether the image window changes its size when you zoom in
or out; you can also change this behavior with a preference.

Context Menus and Tear-offs
Quite a few operations in the GIMP can be accessed via context menus, by using the right
mouse button (or Command-click on the Mac if you still have a one-button mouse). For
instance, layers in the Layers dialog have a context menu associated with them. Right-click
on the line corresponding to a specific layer to see a menu of operations you can run on that
layer.

Some menus, such as the menus in image windows, are also available as menu bars at
the top of the window. But it’s useful to know about the context menus as well, and they
offer some features that the menu bars don’t. The most useful of these features is tear-offs
(Figure 1-5).



Figure 1-6. A torn-off menu

Figure 1-5 shows a context menu expanded several levels deep. Notice the dotted lines at
the top of each menu. These are tear-off lines—think of them as perforations for tearing off the
menu underneath. Click on a tear-off, and the menu under it detaches and becomes a separate
window. This is a useful way to access functions that you need to run often, without having to
navigate the menu system each time. Figure 1-6 shows what a torn-off menu window looks like.
You can move this window to a convenient place on the screen for one-click access to the func-
tions inside. Clicking on the dotted tear-off at the top of the window will close the window.
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Image Window Menus
The image window’s menus, when combined with the tools in the Toolbox, make up the heart
of the GIMP. Everything you’ll need to modify an image should be accessible here.

The File menu contains familiar file operations: New, Open, Save, Save As... Don’t neglect
the Open Recent submenu; you can use it to get back quickly to images you’ve edited in the
past few days.

Edit includes Cut, Copy, and Paste operations, which you will use frequently to move
information between images and layers. Other useful items in this menu are: Clear (which
removes the contents of the current selection) and three variants of Fill. Most of the items in
the Edit menu have keyboard equivalents. You may find you’ll want to learn the shortcuts for
these items since they’re so frequently useful.

The Select menu controls actions that modify the current selection. You can select All or
None, Invert the selection (select everything not currently selected, and vice versa), make the
selection smaller (Shrink) or larger (Grow), or its edges fuzzier (Feather) or sharper (Sharpen).

The View menu controls how you see the image. Items in this menu don’t change the
image that will be saved to disk, merely the way you view it on screen as you edit it. The menu
includes a Zoom control that lets you zoom in or out on the image (this does not make the
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image any bigger or smaller when you save it, it merely changes your view of it), as well as tog-
gles to select whether various attributes such as the selection, guides, rulers, layer boundaries,
grids, and the menu bar are visible.

■Tip An easy item to overlook in the View menu is the very first one: New View. This lets you have more
than one view of the same image. For example, you might have one window showing the image zoomed in
so you can change individual pixels, and another showing the image at normal size to see what the image
will look like when you’re finished. They’re both still the same image as far as the GIMP is concerned: any
changes you make in one view will be reflected in the other.

The Image menu contains functions that apply to the current image as a whole: 

• Image ➤ Duplicate makes a new copy of the image, which will appear in a new window:
this is not a separate view of the same image, as New View would be, but a new image,
with a new name. Changes you make to this image will not be reflected in the original
image.

• Image ➤ Transform provides a quick way to flip an image horizontally or vertically, or
to rotate it 90 or 180 degrees. For more complex rotations, use the Rotation tool. You’ll
learn more about rotation in Chapter 2.

• The rest of the Image menu concerns the image’s size in pixels or your selected units
(Canvas Size...), the image’s print resolution (Print Size...), rescaling of images larger or
smaller (this actually changes the image, unlike Zoom), some cropping and layer utili-
ties, and utilities to handle guides and the grid. All these functions will be covered
thoroughly in subsequent chapters.

The Layer menu contains functions that operate only on the current layer. Some of these
items look the same as items in the Image menu: for instance, Transform, Scale, and Autocrop
appear in both menus. But they’re different: items in the Layer menu only affect one layer and
not the whole image. This distinction will become much clearer in Chapter 3, when you start
to use layers.

The Colors menu contains functions related to the colors of the image, which you will
learn about in Chapter 2. Earlier GIMP versions located this menu inside the Layer menu.

The Tools menu gives you another way to access the tools in the Toolbox window. Most
of the time you’ll probably keep the Toolbox open and access tools that way, so you won’t need
this menu.

The Dialogs menu gives you access to any dialog, whether or not it’s currently visible; it’s
the same as the Dialogs menu in the Toolbox window.

Filters provides access to the plethora of image filters and plug-ins available in the GIMP.
Most external plug-ins you install will also show up in these menus. (In earlier versions of the
GIMP, some of these functions appeared in additional menus such as Script-Fu and Python-Fu.)
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Figure 1-7. Docking bar in the Toolbox window

■Tip In the GIMP 2.2 and earlier, it wasn’t always easy to predict in which of these menus a particular
function would show up. It depended on the language in which the function was written: C, Python, Perl, or
Script-Fu. You’ll learn about these differences in Chapter 11; for now, either explore on your own, or try using
the Plug-in Browser in the Toolbox Xtns menu to locate the function you need.

Functions in all of these menus operate on the current image. Chapter 7 will explore them in much greater
detail. It’s well worth spending a few minutes (which may turn into hours) trying the various filters on an
image to see what they do. You can take a photograph and turn it into an oil painting on canvas, a cylinder or
cone, a rapidly moving blur, or a line-art sketch. You can add borders, drop shadows, or coffee stains. The
possibilities are nearly endless.

Grouping Dialogs by Docking
As mentioned earlier, GIMP dialogs can be grouped together using a process called docking.
For instance, the “Layers, Channels, and Paths” is really three dialogs, but GIMP normally
groups them together as tabs in one dialog.

Docking lets you combine windows in a way that fits your own personal style: you can
have lots of little windows, or you can dock windows together to make one large control win-
dow. (Image windows will still be separate.)

Each GIMP dialog window has a set of docking bars, thin horizontal strips you can use to
add other dialogs to the window (Figure 1-7). There’s usually a docking bar at the top of the
window, another one at the bottom, and, if more than one function is docked into the window,
an additional docking bar below each function.

Separate dialogs (those not currently docked into another window) also have a drag-
handle area (Figure 1-8), including the dock’s title and an area to the right of it, which offers
a place to drag.
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Figure 1-8. Drag handle in the Tool Options dialog

To dock a dialog, drag with the left mouse button from the drag handle into the docking
bar where you want the dialog to end up. The docking bar will light up in a different color when
you drag over it, letting you know that you can release the mouse button and dock your dialog
there. 

■Note In some Windows versions, you may see a cursor shift rather than a color change. Other than that, it
works the same way.

Figure 1-9 shows the Toolbox with the Tool Options dialog docked underneath it. This is
a very common and popular combination, which will probably be the default when you first
start the GIMP.

Notice that when a dialog is docked into another window, its drag handle is still there. You
can use the handle to drag that dialog out of its current window into another window, or onto
the desktop. The “X” at the far-right side of the title area acts as a close button; selecting it will
close that dialog (in this case, Tool Options) entirely. To get it back, use the File ➤ Dialogs sub-
menu from the Toolbox.

What about the arrow button to the left of the close button? 
That’s the Tab menu (Figure 1-10). It allows dialogs to be added as tabs, as in the “Layers,

Channels, and Paths” dialog, or existing tabs to be detached or closed. Tabs can also be re-ordered
simply by dragging them. In some dialogs, other options are added to the Tab menu.
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Figure 1-9. Tool Options docked below the Toolbox

Figure 1-10. The Tab menu


