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Dear Reader,

Thank you for choosing Maya Visual Effects: The Innovator’s Guide, Second
Edition; Autodesk Official Press. This book is part of a family of premium-quality
Sybex books, all of which are written by outstanding authors who combine practical
experience with a gift for teaching.

Sybex was founded in 1976. More than 30 years later, we’re still committed to
producing consistently exceptional books. With each of our titles, we’re working hard
to set a new standard for the industry. From the paper we print on to the authors we
work with, our goal is to bring you the best books available.

I hope you see all that reflected in these pages. I'd be very interested to hear your
comments and get your feedback on how we’re doing. Feel free to let me know what you
think about this or any other Sybex book by sending me an email at nedde@wiley.com. If
you think you’ve found a technical error in this book, please visit http://sybex.custhelp.
com. Customer feedback is critical to our efforts at Sybex.

Neil Edde

Vice President and Publisher
Sybex, an Imprint of Wiley

Best regards,



neede@wiley.com
http://sybex.custhelp.com
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For all my students and all my teachers. Let’s make
something cool today!
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Introduction

Be creative is the one instruction I find in many CG books
that always makes me laugh out loud. Why is the author tell-
ing me to be creative? If  wasn’t a creative person, 1 wouldn’t
be interested in computer graphics in the first place.

It always seems to me that authors of tutorials use the phrase be creative when
they are not exactly sure what to say. But upon reflection, it’s not really a bad piece of
advice if you stop to think about what drives the creative process. Creativity is the abil-
ity to make connections between two or more seemingly unrelated things. For example,
when chemicals were exposed to light in a particular way, the art of photography was
born. Sound vibrations used to carve grooves into a wax tube gave birth to recorded
music. The aha! moment occurs when an artist suddenly realizes that what makes art
more than the sum of its parts is the way in which those parts are connected. When
successful, this realization is shared by the audience in the form of an experience that
feels new and reveals something about the universe that may not have been immediately
apparent before. It sounds like lofty stuff, but this is the whole point of creativity; it is
an exploration of what new things can be made with the existing tools we have before
us. Innovation is the word used to describe the process of making these types of con-
nections. Innovation is the engine of creativity.

Autodesk® Maya® is all about connections. It’s a virtual world made of nodes . . .
individual packets of data. A Maya scene is just a bunch of nodes connected together.
This is clearly illustrated in any number of Maya interface panels such as the Node
Editor, Hypergraph, Outliner, Hypershade, and many others. When you first learn
Maya, you generally go through the tutorials that are meant to show you how to con-
nect these nodes in their intended arrangements in order to create the types of anima-
tions you commonly see. Most tutorials will take you through the process of how to
use joints to make a character walk, how to create snow using particles, or how to
make a ball bounce using the Graph Editor. These are all important, even crucial, skills
to learn. Unfortunately, most tutorials stop there, leaving you to wonder what’s next.
There is a gap in Maya training between the beginner tutorials and the advanced tutori-
als. This book is meant to bridge that gap. I wanted to create a series of fun tutorials
specifically for the student who has completed the basic training but is not yet ready
for the advanced techniques. The goal of this book is to help you understand that the
true power of Maya lies in its ability to make connections in interesting ways; in other
words, how to be creative in Maya.

The techniques in this book are just ideas meant to inspire you. They are culled
from my own experience working as a professional in the industry. The audience is
expecting to be surprised, your art director is looking for something that hasn’t been
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done, and the client wants to set themselves apart from their competition. In these
situations, simply being a master of tried-and-true techniques is not going to keep you
employed. These situations call for innovation and creativity. You need to think on
your feet and be fearless about taking risks. How you solve problems, how you con-
nect the various nodes within Maya, is what is going to set you apart from the CG art-
ists who are content to simply repeat the same techniques everyone else has been using
for the past 20 years.

My hope is that by going through these tutorials you’ll acquire a deeper under-
standing of how Maya works and this will help you to develop your own Maya inno-
vations when confronted with a challenge on a job or with one of your own projects.

I sincerely doubt that I should see one of my techniques used verbatim in a movie or a
commercial. That’s really not the point of this book. The point of this book is to help
you discover ways in which you can use Maya to be creative.

Who Should Buy This Book

This is not a beginner Maya book, nor is it a comprehensive guide to every tool in
Maya. If you are new to Maya, I recommend you first familiarize yourself with the
basics, the interface, and the tools. I recommend a book such as Introducing Autodesk
Maya 2014 by Dariush Derakhshani (Sybex, 2013) as well as the Maya documenta-
tion. The Innovator's Guide is comprised of 24 tutorials loosely categorized by Maya
features. It is meant for students who are looking to take their Maya skills to the next
level. It’s also for the professional who is looking to deepen their skills perhaps in an
area of Maya they are not familiar with. ’ve had some wonderful feedback on the
first edition of this book, which was written in 2006. Many professionals have told
me that the tutorials were a great source of inspiration when they were stumped by

a tricky problem that lacked an obvious solution. Bottom line, if you have not used
Maya before or if you’re an expert in another piece of CG software such as 3ds Max,
buy this book, but then set it aside; spend some time learning Maya and then pick this
book up when you’re ready to improve your skills.

This book was written using a prerelease version of Maya 2014, but many of
the techniques can be used in older versions of Maya, at least as far back as version
2011. There are a few exceptions, including the Maya Hair tutorials, which use fea-
tures introduced in Maya 2013, but with some thought and creativity even these tech-
niques can be applied to older versions of Maya. So, if you don’t have the very latest
version, not to worry, you should still be able to get a lot out of this book.

What'’s Inside

The lessons in this book are loosely grouped by Maya tools, but that’s not to say you
won'’t find nParticle techniques demonstrated in the chapter on textures or nCloth
techniques in the chapter on nParticles. Each chapter consists of three tutorials
demonstrating some neat ideas of how the Maya tools can be connected in interest-
ing ways to achieve a particular effect. Each tutorial presents a problem you might



encounter as a Maya artist working in a small studio. These scenarios are based on
my experience working as a freelance artist in Hollywood. I tried to make the tutori-
als fun and engaging as well as short. At the end of each tutorial is a short section
called “Further Study” that has suggestions of how you can build on the techniques
you’ve just learned.

Many of the tutorials are accompanied by a mini-lesson on Maya Embedded
Language (MEL) scripting. MEL is a scripting language used to automate repetitive
tasks in Maya as well as add additional functionality. My good friend Max Dayan,
himself an accomplished professional Maya artist and an instructor at the Gnomon
School of Visual Effects, has written these scripts along with a short description of the
logic he used to write them.

These scripts are “learning scripts;” in other words, they were created to help
you understand the techniques of the lessons as well as how to write better scripts. In
a professional setting, Max’s scripts would be more efficient but more difficult for a
student to understand, so in some cases he has sacrificed a small amount of efficiency
to maximize clarity. If you are not interested or you’re intimidated by MEL scripting
(and many artists including myself are not necessarily master programmers), you can
feel free to skip these sections and return to them later when you feel like you want to
dive in to the world of MEL scripting.

If you’ve never written an MEL script before, you should spend a little time
familiarizing yourself with Maya’s Script Editor. I recommend reading through the
Scripting section of the Maya documentation so that you understand how scripts are
entered into the Script Editor or written in an external text editor, what it means to
source a script, and how to create a shelf button from a script.

The tutorials in each section have accompanying scene files that you can use
to follow along. There is no DVD with this book; instead, we have decided it’s more
efficient to provide a link to the Sybex website where the project files can be down-
loaded. Each chapter of this book has its own project file that contains everything
you need to follow along. To retrieve the file, simply use your web browser to go to
this address: www.sybex.com/go/mayavisualeffects2e. Here, you’ll find the projects in
zipped archives as well as instructions on how to use them. As you start each chapter,
make sure you use the File menu to set the current Maya project to the appropri-
ate chapter project. This way, textures, caches, and other externally linked files will
behave predictably.

The chapters do not need to be read in order; each lesson is self-contained, so
feel free to skip around between the chapters and their tutorials as you like. The dif-
ficulty of each tutorial ranges from easy to intermediate with a few extra advanced
challenges thrown in for fun. Here’s a description of what you’ll find in each chapter:

Chapter 1: Texture Effects This chapter contains three tutorials designed to approach tex-
turing with some interesting twists. Learn to create an interactive animation control
for lighting up a demonic neon sign using a ramp texture, create holographic effects
using the ambient occlusion texture node, and create scrolling text for a blimp sign.

NOILONAOYLINI m %
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Chapter 2: Particle Effects One of the most powerful animation tools in Maya is the hum-
ble particle. These tutorials give you a small taste of the kinds of things you can do
with some clever tricks. You’ll create a dynamically blossoming cherry tree, grow a
beard of bees for a character, and create an animation control panel that can choreo-
graph a school of swimming fish.

Chapter 3: Joint Rigging for Effects Joints can be used for a lot more than character anima-
tion. This chapter has three challenges designed to inspire you with ideas for how
you can exploit the power of Maya’s skeleton tools. Joints are used to create a creepy
undulating mass of tentacles, unroll a magic brick path through a forest, and create a
growing mass of bacteria by combining joints and particles.

Chapter 4: Creative Blend Shape Techniques Blend shape deformers are easy to set up and
animate. Because of this, they can easily be combined with deformers to create some
unique effects. In this chapter, you’ll create an interactive rig that can be used to coax
abstract designs and motion from a field of bocks, you’ll build a small population

of swimming plankton by layering simple deformers, and finally you’ll learn how to
write an MEL script that automates the setup of complex blend shape sequences.

Chapter 5: Paint Effects Paint Effects is Maya’s own procedural modeling tool commonly
used for creating plantlife. In this chapter, you’ll learn some cool tricks for using Paint
Effects as a solution to some interesting problems. You’ll learn how to instance ani-
mated lightning bolts to particles, animate an eye suffering from an alien infection,
and use Paint Effects as a way to deform geometry.

Chapter 6: nCloth Techniques Maya’s nCloth is an easy-to-use system for creating soft body-
style dynamic effects. Beyond its obvious application for adding dynamic motion to

a character’s cloth, it also has a myriad possibilities as a solution for problems posed
by unconventional animation. In this chapter, you’ll use nCloth as a way to melt the
metal of a complex gun model, you’ll create an animated spider web by combining
nCloth and Paint Effects, and you’ll animate a drop of water rolling off a blade of
grass.

Chapter 7: Fluid Effects Maya’s Fluid Effects can be intimidating to a new user, but they’re
actually quite easy to use and, when combined with other dynamics, very powerful
effects tools. In this chapter, you’ll use 2D fluid containers to create a 3D shock wave,
propel a rocket with nParticles and fluids, and construct the head of an android from
floating gooey blobs.

Chapter 8: nHair and Fur Effects Maya’s nHair system and its fur tools aren’t just for char-
acters and creatures; they can also be used as animation tools. In this chapter, you’ll
build an undulating jellyfish by lofting geometry from dynamic hair curves, create a
rig for Medusa’s head of snakes, and animate an alien design in a crop field.

How to Contact the Author

I enjoy hearing from the readers of my books. Feedback helps me continually improve
my skills as an author. You can contact me through my website, www.bloopatone.com,
as well as see examples of my own artwork there.



Sybex strives to keep you supplied with the latest tools and information
you need for your work. Please check the book’s website at www.sybex.com/go/
mayavisualeffects2e, where Sybex will post additional content and updates that
supplement this book should the need arise.

NOILONAOYINI B 5,
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Texture Effects

All too often textures are overlooked as a
solution for creating effects. The tendency is
to think of textures as simply a means for col-
oring objects. The tutorials in this first chap-
ter demonstrate some ways in which engaging
visual effects can be created quickly and eas-
ily simply by taking advantage of the power

that textures have to offer.

Chapter Contents

(reate Animated Lighting Effects with a Ramp Texture
Use Ambient Occlusion for Holographic Effects

Use Creative Text Effects

SLOdddd YN LXTL W =



CHAPTER 1: TEXTURE EFFECTS B N

Create Animated Effects with a Ramp Texture

This first challenge involves adding an effect to the opening shot of an animated short.
Figure 1.1 shows part of the storyboard for the opening. The camera moves down

and out to reveal a dilapidated hotel sign with some broken lights. The gag is that the
lighted parts of the sign spell “Hell.” The neon vacancy sign is just barely hanging on.
The director would like to suggest that the hotel is possessed by demons, so as the cam-
era stops, the Vacancy sign lights up, one of the bolts gives away, and the sign swivels
so that the arrow points downward. Subtle, no?

Figure 1.1 The storyboard shows a neon sign magically coming to life.

Rather than have the sign blink on like a real neon sign would, the director
would like the light of the neon Vacancy sign to start at the letter V and travel to the
end over the course of about a second. A particle effect should be added to the leading
end of the light.

The sign has already been modeled, and the basic camera move, along with the
animation of the broken sign, is established. For the Vacancy sign, there is a NURBS
curve but no neon geometry as of yet.

This effect should be fairly easy to create by extruding geometry along the
length of the curve. A shader can be applied to the geometry, and then an animated
ramp attached to the incandescence of the shader will provide the lighted effect.
Whenever you’re confronted with an effect, it’s a good idea to design a rig with a few
simple controls that can be easily animated. Whenever possible, the rig should be set
up to anticipate changes as easily as possible because art directors are fussy and tend to



change their minds a lot. This tutorial will take you through the steps of setting up a
rig so that one control can be used to animate the light traveling along the length of the
word Vacancy as well as the position emitter for the particle effect.

This exercise demonstrates one way of creating the rig and introduces you to
several methods for navigating the node hierarchy in Autodesk® Maya®. Every Maya
artist has their own style of working, but once in a while it’s a good idea to explore
alternative methods of navigating the Maya interface. Doing so will open possible
workflows that you may not be aware of, which can increase your efficiency as well as
your understanding of how Maya works.

Create the Sign Geometry

The geometry for the Vacancy sign can be extruded along the existing curve in the
scene. Before you start extruding geometry using NURBS geometry, I suggest you
consider applying a Paint Effects stroke to the curve and then convert the stroke into
polygons. The reason for this is that it’s easier to control the twisting and pinching that
may occur as the geometry follows the curve. In addition, the UV texture coordinates
created by the Paint Effects geometry will be easily adapted so that the ramp that cre-
ates the neon light can be animated without too much work.

1. The project files for this chapter can be downloaded from from the book’s support
site. Use your web browser to navigate to www.sybex.com/go/mayavisualeffects2e
and download the Chaptero1_project. Once the files have been downloaded, unzip
them to your local drive. Open Maya and use the File menu to set the Project to
Chapter@l_project. Then open the signSTart.ma file located in the Scenes directory
of the Chapter@1_project file directory. Once the scene is open, switch to the Persp
camera using the View menu in the main viewport.

2. In the Outliner, expand the vacancy_sign group, and select the curve node
named vacancyNeonCurve (see Figure 1.2).

EBan OF9see ),

Figure 1.2 Select the vacancyNeonCurve node in the Outliner.
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Switch to the Rendering menu set, and choose Paint Effects > Curve
Utilities » Attach Brush To Curves (see Figure 1.3). The default stroke, which is
a thick black line, is applied to the curve.

m Paint Effects

Paint Effects Tool O
Make Paintable

Muscle Pipeline Cache Help I\ 7 5 ﬂ

/signStart.ma* --- vacancyMNeonCurve

Get Brush...
Template Brush Settings... #B
Reset Template Brush

Flip Tube Direction

 Paint on Paintable Objects
Paint on View Plane

Apply Settings to Last Stroke
Get Settings from Selected Stroke
Apply Settings to Selected Strokes

Share One Brush
Remove Brush Sharing
Select Brush/Stroke Names Containing...

Create Madifier

Brush Animation
Curve Utilities
Auto Paint

Simplify Stroke Path Curves
Set Stroke Control Curves
Attach Brush to Curves
Transfer All Strokes to new Object
Make Pressure Curve

Paint Effects Globals
Mesh Quality Attributes

Preset Blending jm}
Save Brush Preset...

Figure 1.3 Use the Paint Effects menu to attach the default brush stroke to the curve.

Select the Strokel node in the Outliner, and open the Attribute Editor.

To convert the stroke into geometry, choose Modify > Convert > Paint Effects
To Polygons » Options; in the options, turn on Quad Output and Hide Strokes.
Maya creates a new node for the converted geometry and places it in a group called
brush2MeshGroup. Expand this group, and select the brush2Main node. Press
Shift+P to unparent the mesh, which moves it out of the group brush2MeshGroup.
Double-click the brush2Main node in the Outliner so it becomes highlighted,

and rename the brush2Main node to vacancyNeonGeo. You can select and
delete the brush2MeshGroup node (see Figure 1.4).

Figure 1.4 Convert the Paint Effects stroke into polygons. Ungroup the node, and name it vacancyNeonGeo.



Make sure you do not delete the Strokel node and don’t delete the history on the

vacancyNeonGeo node. Since the stroke is applied to the curve that is contained inside

the vacancy_sign group, which is keyframed, the vacancyNeonGeo node will inherit

the animation (see the sidebar “Construction History” for information on how this

works). The advantage of keeping the history on the vacancyNeonGeo node is that you

can change the width and other attributes of the vacancy geometry by tweaking the

settings on the strokel node. This is helpful if a picky art director decides changes need

to be made to the sign at some point in the future.

Construction History

Maya keeps a record of all the changes that go into the nodes that you create when you model
an object as well as how different nodes may be connected. This is known as construction history.
When you create a model such as the neon sign, Maya remembers that the surface of the neon
tube was created when you attached a Paint Effects stroke to the tube and that you then con-
verted the tube into polygons. So, if you make changes to the original curve or the Paint Effects
stroke, the changes propagate all the way to the polygon surface of the tube; thus, the polygon
tube “inherits” any changes you make to the original curve or any of the other nodes that went
into the construction process. You can take advantage of construction history when you animate
the nodes that are connected through construction history. You can toggle construction history
on or off by clicking the history script icon JES=I{lE located on the status bar.

Set Up the Neon Shader

Here’s where the fun begins. To create the effect of the light traveling along the length

of the neon tube, youw’ll attach a ramp to the incandescence channel of a Blinn shader.

1

Open the Hypershade to find the shader named neonGlassBlinn. This is a simple
shader that has already been set up to create the look of the neon glass. Select
the shader, and MMB drag it on top of the vacancyNeonGeo in the Perspective
view.

In the Hypershade, select the neonGlassBlinn shader, and open its settings in the
Attribute Editor. Click the checkered box to the right of the Incandescence chan-
nel to open the Create Texture Node panel.

Select the 2D Textures category on the left side of the panel, and click Ramp to
create a ramp node (see Figure 1.5). Hold the mouse pointer over the Perspective
view, and press the 6 hotkey to switch to textured view. Make sure that the
Renderer panel in the viewport window is set to High Quality Rendering;
otherwise, you won’t see the ramp texture update properly as it’s applied to the
geometry.

In Perspective view, the rainbow pattern of the ramp appears on the neon tube,
but it is a repeating pattern that looks more festive than demonic. To fix this,
you can adjust the UVs of the vacancyNeonGeo node.

JYNLXTL dNVY V HLIA SLOdddd A4LVININY dLVAIO ® »n



CHAPTER 1: TEXTURE EFFECTS m O

Create Render Node
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Figure 1.5 Use the Create Render node panel to attach a ramp texture to the Incandescence channel of the neon-
GlassBlinn material.

Select the vacancyNeonGeo node, and choose Window > UV Texture Editor.

If you zoom out (waaaaay out), you’ll see that the UVs are a long vertical strip.
In the UV Texture Editor’s menu panel, expand the Textures menu, and select
vacancyNeonGeolblinn2SGlrampl so that the ramp appears in the UV Texture
Editor.

As you can see, the rainbow colors of the ramp appear in the upper quadrant of
the UV Texture Editor. What you don’t see is that outside of this area, the ramp
texture repeats over and over to infinity, which is what the colors on the neon
tube continually repeat; the UVs for the tube continue well outside of that upper

quadrant (see Figure 1.6).

ghif - Renderer . UV Texture Editor
o EmEAESE R & S s Too

vacancyNeonGea | blinn2SC | rampl
1 B

Figure 1.6 The UV Texture Editor shows that the UV texture coordinates of the neon sign geometry go well beyond the
upper quadrant of the texture space. The result is that the ramp texture repeats along the length of the glass tube.



1.

Right-click the UVs, and select UV from the marking menu. Select some of the
UV coordinates in the editor (the selected coordinates will be highlighted in
green). Hold the Ctrl key, right-click again above the selected UVs, and choose
To Shell from the marking menu. This selects all of the connected UVs of the
glass tube geometry.

From within the UV Texture Editor, choose Polygons » Normalize. This forces
the UVs to fit within the upper-right quadrant of the UV texture space. Now the
ramp is no longer repeating. The UV coordinates will look fairly dense in the
UV Texture Editor, but in Perspective view, you’ll see that the ramp goes from
red to green to blue across the length of the sign.

Select the ramp1 node on the Textures tab of Hypershade, and open its settings
in the Attribute Editor.

Click the x at the top of the ramp to delete the blue color at the top of the ramp.
Set the middle color to black; then set Interpolation to None.

Set the bottom color to a devilish shade of red.

Try dragging the circle for the black color up and down; you’ll see the light move
along the neon tube (see Figure 1.7). Name the ramp node neonLight.

Figure 1.7 Move the black color of the ramp up and down; the color updates on the tube geometry in Perspective view.

To make the sign easier to read, you can apply a separate dark shader to the
parts of the tube that connect the letters. This replicates the way actual neon
signs are constructed in the real world, adding an extra touch of realism.

Right-click the vacancyNeonGeo geometry in Perspective view, and choose
Face. Carefully select the individual faces connecting the V and the A. Once
they are selected, switch to the Rendering menu set, and choose Lighting/
Shading > Assign Favorite Material > Lambert. This creates a new Lambert
shader and applies it to the selected faces. Do the same for the other parts of
the sign. Assign the same Lambert shader to these selected faces (you can use
Lighting/Shading > Assign Existing Material to do this easily). Figure 1.8 shows
the result.
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12.  Edit the Lambert shader that has been applied to these faces so that the Diffuse

color is a very dark gray.

ate  Display ) Texturing Render Toon

Material Attributes

Assign New Material...
Assign terial
Assign Existing Mate A
Assign New Bake Set (mental ray) Layered Shader
Assign Existing Bake Set (mental ray) Phong
Batch Bake (mental ray) Phong E
Transfer Maps... Ramp Shader
Surface Shader
Make Light Links. Use Background
Break Light Links - .
Select Objects llluminated by Light + Automatic Attribute Editor
Select Lights Illuminating Object
Light Linking Editor

Make Shadow Links
Break Shadow Links

Select Objects Shadowed by Light
Select Lights Shadowing Object

Figure 1.8 To make the sign easier to read, select the faces between some of the letters, and apply a dark gray Lambert
shader.

Create an Animation Control for the Sign

At this point, you could consider yourself done, but before you declare “mission
accomplished,” you should take some time to set up an animation control. Taking
the time to do this now can save you trouble later when the director starts asking for
tweaks on the animation. In addition, any animators you share the project with will
appreciate not having to hunt around to find the keyframed attributes within the many
panels Maya has to offer.

You can create custom controls in lots of ways. In this example, you’ll create
an arrow-shaped control using a NURBS curve. When the control is connected to the



ramp, dragging it back and forth will control the progress of the light along the sign.
This way, the animation can be controlled directly in Perspective view, eliminating the
need to hunt around for the animated settings in the Attribute Editor.

1. Switch to a front view, and zoom in on the sign. Turn on the grid using the View
menu in the upper left of the viewport.

2.  Choose Create > EP Curve Tool » Options. In the Options, set Cure Degree to
Linear. This option means that the curves will be straight lines.

3. Activate Snap To Grids by clicking the icon that looks like a magnet over a grid
on the top menu bar of Maya. Create a straight line by clicking two different

points below the sign, as shown in Figure 1.9.

Figure 1.9 Create aline below the Vacancy sign using the EP Curve tool (top image). Create a triangle below the line
(bottom image).

4.  Double-click the curve in the Outliner, and name it lightControl. This line will
provide a visual indication for the length of the control.
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10.

Using the EP Curve tool again, click three times to create a triangle just below
the line. Name the triangle lightControlHandle. This triangle will be the actual
control that is used to animate the light of the sign (see the bottom image in
Figure 1.9).

Select lightControlHandle; then Shift+select the light control. Press the P hotkey
to parent the lightControlHandle to the lightControl. Turn off the grid so you
can easily see the control curves.

Select lightControlHandle, and choose Modify > Center Pivot. Open the
Attribute Editor for the lightControlHandle. Make sure the tab in the Attribute
Editor is set to lightControlHandle and not lightControlHandleShape. You’re
going to set translation limits on the handle, so you want to make sure you’re
working on the transform node of the curve and not the shape node.

Expand the Limit Information rollout; then expand the Translate rollout within
this section. Move the lightControlHandle to the left end of the line, and click
the arrow to the left of the Current setting, as shown in Figure 1.10. Click the
check box next to Trans Limit X to set the minimum value.

List Focus

lightControlHandle lightCor

Focus

transform: |ightCor e Presets

Hide =

Transform Attributes

Pivots
Limit Information

Translate

Trans Limit X
Trans Limit ¥ v 0.00
Trans Limit Z v 0.00

Rotate

scale Figure 1.10 Set the minimum and
Display

maximum Translate values for the handle

mental ray

Node Behavior so that it does not go beyond the length of

Extra Attributes

the lightControl curve.

Move the lightControlHandle all the way to the right, and use the same tech-
niques to set the Max setting. Once this is set, the lightControlHandle is
restricted on the X axis so that it can’t move beyond the length of the line.
Set the Min and Max values for Trans Limit Y and Trans Limit Z to 0 so
that the lightControlHandle can’t be moved along these axes by mistake (see
Figure 1.10).



