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Introduction

ou’ll often hear two comments from nearly anyone
who has played any version of Farming Simulator
released in the last few years.

+ “I had no idea this game would be so addictive.”
A person often gets the game on a lark, purchasing
it from a favorite retail outlet or downloading it via
Steam or www . farming-simulator.com. You then
start playing. The next thing you know, hours have
flown by and you’re eyeballing a new fork for the
front loader you just bought so you can move more
bales around your steadily growing farm. It’s not at
all uncommon for a person to dump more than a
100 hours of gameplay into Farming Simulator within
only a few weeks. Only then does it begin to sink in
as to why this game has become so incredibly popu-
lar, with more than 5 million copies sold worldwide.

v “I didn’t realize how incredibly large and active
the modding community is for this game.” Mod
is short for modification, and GIANTS Software
has made it incredibly easy to make modifications
to Farming Simulator and share those mods with
others. If you want proof of how big modding is for
this game, type “farming simulator mods” into your
favorite search engine. On even a basic search, you
can find more than a dozen different mod communi-
ties for Farming Simulator, each one with more than
1,000 unique mods. In fact, more than 15,000 mods
have been created just for Farming Simulator 2013!
You can find everything from a simple ramp or new
tractor to custom maps and reconfigured game
mechanics. There’s even a mod that turns Farming
Simulator into a flight simulator! And the commu-
nity creates more mods each and every day. There’s
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something incredibly rewarding about making your
own custom thing for a game — taking ownership of
it, if you will — and then actually using it in the game
environment with others.

So Farming Simulator is not only a lot of fun to play, but
it’s also equally fun to customize.

About This Book

Farming Simulator Modding For Dummies serves as a refer-
ence for each step in the process of making mods. That
process is simultaneously artistic and technical, spanning
a wide array of tools and disciplines. For this reason, you
often see people group together and form mod teams,

so individuals with a more specialized skill can focus on
what they’re good at. If you’re making the full mod your-
self, this book can help guide you through it. If you're one
person on a team, the book covers your specialization
while also giving you an understanding of what the other
members of your team need (as well as what you should
expect from them).

This book isn’t large enough to be comprehensive, so

I focus on just what you need to know to start building
mods. Some subjects simply are out of scope. For exam-
ple, on the art side, I cover polygon budgets for models
and the process of getting your 3D models properly
optimized for the Farming Simulator engine, but there
isn’t enough room to cover 3D modeling as a topic. (That
would be a book by itself!) Likewise, on the technical side,
I can show you the structure of the modDesc . xml file and
introduce the possibilities in customizing your mod with
Lua, but you’ll need to look online for the full APL

All the screenshots were taken on a computer running the
Windows operating system. Although Farming Simulator
does run on Mac OS X, most of the modding community
uses Windows. Generally, there aren’t too many differences,
but I make note of where they do crop up. On a related
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note, if you're using a Mac and only have a trackpad, I can’t
emphasize enough the value in working with a proper three-
button mouse. Most applications that work in 3D, including
the ones covered in this book, expect you to have one. If
you’re adept at using the trackpad and gestures to simulate
a three-button mouse, you may be fine, but advanced ges-
tures like pinching and rotating aren’t likely to work for you.

Also, when it comes to creating 3D content for your mods,
you can use a wide variety of tools. This book references
the three most common ones used in the Farming Simulator
modding community: Blender, Maya, and 3ds Max. Because
it’s free (and because it’s my personal favorite), most of the
references in this book focus on Blender. When something
is specific to Maya or 3ds Max, [ point it out.

As I discuss various software programs in this book, I

tell you how to find an operation in a menu using this
symbol:=, such as “Go to File>Open to open a file.” That
said, regardless of the program, | have a preference for
using hotkeys because they’re much faster. So where pos-
sible, I lead with the hotkey combination and include the
menu navigation in parentheses. For example, “Open the
file by pressing Ctrl+O (or File=>Open in the menu).”

Foolish Assumptions

I assert a few assumptions about you in this book. In list
form:

+* You have a computer capable of running Farming
Simulator and GIANTS Editor. It’s pretty difficult to
know if your mod works if you can’t play the game.
The system requirements for these are pretty modest;
please refer to the manual for specifics.

+* You have a basic understanding of 3D graphics.
You don’t need to be a professional video game pro-
grammer. If you know how to navigate in a 3D game
and select things, that should be enough to get you
started.
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+* You're comfortable editing text files. A lot of mod-
ding involves making adjustments to text files using
a program like Notepad++. You can write them from
scratch, but to start, you just need to know how to
open them, make changes, and save.

[ also assume that you can access the Internet from time
to time. You don’t need an Internet connection to make
your mod, but a number of useful online resources are
available, and you definitely need the Internet if you want
to share your mod with others.

Beyond This Book

As this book is intended to give you a good, solid start in
making mods for Farming Simulator, additional resources
of information are available at your fingertips. Chapter 15
has a slew of these resources listed. However, other mod-
ders are the greatest source of information. The official
forums on the GIANTS Developer Network (http://gdn.
giants-software.com) and the Farming Simulator
website (http://forum.giants-software.com) are a
great start, but look at mod groups and mod hosting sites
that are local to you as well. They're fountains of informa-
tion as well as people willing to help.

lcons Used in This Book

3
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These icons that appear in the book’s margins can help
you navigate your way through the book. Here is what
they mean.

This icon calls out suggestions that help you work more
effectively and save time.

Keep these useful pointers in mind as you produce your
mods. Generally, you'll regularly encounter these things
as you're working.


http://gdn.giants-software.com
http://gdn.giants-software.com
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Y These icons point out moments that can get you pulling
out your hair in frustration if you get caught in one.

Where to Go from Here

[ am tempted to say, “To the fields!” Of course, you're
making modifications for a game that simulates farming,
so perhaps a bit of silliness is to be expected. If you're new
to modding, then it makes the most sense to start at the
beginning and work forward sequentially from Chapter 1.
If you're familiar with modding, but you want to get up

to speed with the specifics of creating mods for Farming
Simulator, peruse the Table of Contents and find the
chapter(s) that most interest you and read what you need.

Now, to the fields!
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In this part . . .

Discover what modding is and the different ways
that you can make changes in Farming
Simulator

Understand the fundamental tools used for modding
Farming Simulator so you can begin creating your
own mods

Create map mods with your own custom terrain and
foliage around buildings and other props as you
see fit

Familiarize yourself with how to control surface
materials in Farming Simulator’s 3D world

Get a taste for how particles are used in a mod to
bring life and realism to the game




Chapter 1

IntroducinMNTS Editor

In This Chapter
Understanding the GIANTS Editor interface
Opening 3D objects and scenes in the editor
Moving around within a 3D scene in GIANTS Editor

Moving, rotating, and scaling objects

A Il modding for Farming Simulator starts and ends
with GIANTS Editor. If you want to make a quick
change to a map or a vehicle, you can open its file and
edit attributes in GIANTS Editor. If you've created a full
mod from scratch, you pull all the pieces together and
prepare them for inclusion in the game in GIANTS Editor.
Think of GIANTS Editor as your modding dashboard.

You don’t need to do a lot in order start working with
GIANTS Editor; it ships with Farming Simulator. So if
you've been playing the game, you're good to go with the
editor; you just need to install it. You can find the install
file in the sdk folder wherever you've installed Farming
Simulator on your hard drive. (On a Windows computer,
it’s usually something like C: \Program Files (x86)\
Farming Simulator 2015.) Of course, going to the
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GIANTS Developer Network website (http://gdn.
giants-software.com) and checking for updates is
still a good idea. That way you can be sure you get the
latest features and bug fixes. Updated versions of the
editor are free to download after you've registered on the
site (which is also free).

This chapter serves as your jumping-off point into the
world of creating mods for Farming Simulator by making
sure you have firm footing when it comes to using GIANTS
Editor. Regardless of how simple or complex your mod
may be, it needs to come through GIANTS Editor, so this
chapter is relevant, no matter your general modding
experience.

Knowing the Editor’s Parts

When you first launch GIANTS Editor, you'll see a Getting
Started splash window that provides you with a hotkey
reference and a set of buttons that links you to a number of
useful resources to help quickly get you on the road to mod-
ding. You can toggle whether this window appears every
time you launch it by clicking the Show at startup check-
box in the window’s lower-left corner. These resources
are certainly valuable, but you also have this book, so you
can comfortably close this window for the time being. You
can always bring it back from the Help menu in the editor
(Help=>Getting Started . . .).

After you move past the splash window and actually

get into the editor, you may think it looks rather stark,
consisting of a set of mostly empty panels. Not to worry,
though, those panels will fill up pretty quickly. Figure 1-1
shows GIANTS Editor with the default interface and a
scene already loaded.


htttp://gdn.giants-software.com
htttp://gdn.giants-software.com
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Figure 1-1: The GIANTS Editor default interface.

‘&&N\BER
& You can see four main panels when you first load GIANTS
Editor:

»* Scenegraph: You can find the Scenegraph on the
far left of the editor window. The Scenegraph gives
you a hierarchical view of the 3D scene, including all
models, lights, and cameras. Think of it as an outline
for your mod. In complex scenes, the Scenegraph
panel is incredibly useful for selecting the object
you're interested in editing.

v+~ 3D Viewport: The 3D Viewport is the large panel at
the center of the editor window and is where the
majority of your work takes place. Here you can
select and manipulate objects in your mod; the 3D
Viewport also provides a decent preview of what
you can expect your mod to look like after you load
it into Farming Simulator.

v+~ Attributes: The Attributes panel on the far right of
the editor window can show different settings and
parameters, depending on the object you currently
have selected. At the very least, any object you
select will have Transform attributes for controlling
how that object is positioned and oriented in 3D
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space. From there, depending on what the object is
and what it does, it may have a wide variety of poten-
tial other subtabs available in the attributes panel.
For example, in Figure 1-1, the selected building in
that scene has a separate tab labeled LOD, for level
of detail.

v Scripting: The Scripting panel is across the bottom
of the editor window. This panel gives you a log and
basic feedback on what’s been done in your scene,
such as loading external textures. It can also give
you warnings if you have missing assets or if you've
formatted something incorrectly in your mod. When
things go pear-shaped in your mod, the Scripting
panel is your best friend for troubleshooting what
happened. And, of course, you can use the Scripting
panel to type commands and make large automated
changes to objects in your scene. Chapter 12 discusses
scripting in greater depth.

With the exception of the 3D Viewport, you can move
around any panel in the GIANTS Editor interface by click-
ing and dragging the panel’s header bar. Doing so allows
you to place the panel in another location or leave it as its
own floating window. Being able to customize your inter-
face is especially useful if you're working on a computer
with multiple monitors. You can keep the 3D Viewport as
big as possible on one monitor and move the other panels
to your other monitor. Also, you can close any panel by
clicking the little X on the right of the panel’s header. You
can bring back any closed panels from the Window menu.

Loading Assets

The file format that GIANTS Engine uses is the I3D format.
I3D is an eXtensible Mark-up Language (XML) file format.
That means, in part, that you can open it with a plain text
editor and make changes to it. Chapters 6 and 11 discuss
I3D and XML more.
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For the purposes of this chapter, you just need to know
that an I3D file encapsulates or references all the necessary
data for a 3D asset in GIANTS Engine. That also means [3D
files are what you load and modify from GIANTS Editor for
your Farming Simulator mod. This section explains how to
open full maps as well as individual assets that may appear
on a map.

Opening an existing map

The easiest asset to open in GIANTS Editor is the default
map that comes with Farming Simulator. Go to File=>Open
in GIANTS Editor and navigate to the maps folder within
the folder where you've installed Farming Simulator (typi-
cally C:\Program Files (x86)\Farming Simulator
2015\data\maps) and choose the file named map01.1i3d.
You should see the familiar original map in the 3D Viewport
after it finishes loading. Figure 1-2 shows the default Farming
Simulator map loaded in GIANTS Editor.

mesnszoi L | ]

= [P

Figure 1-2: The default Farming Simulator map (map01 . 13d) opened
within GIANTS Editor.

Do not save or overwrite the default Farming Simulator
map, especially if you've made any changes to the file. At
the very least, doing so may change the default behavior of
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the game. At worst, it may cause the game not to load and
force you to reinstall it. Although Chapter 2 covers export-
ing the original map for modifications, right now your main
focus should be on loading the map in GIANTS Editor and
poking around to familiarize yourself with the interface.

Using this same basic method you can open any map
scene. If you have any map mods installed, you can try
opening up the map scenes from them as well.

Previewing objects

A Farming Simulator map is really a compilation of dif-
ferent 3D assets, including props, terrain, buildings, and
so on. Suppose you’re not interested in working with a
full map, and you only want to have a look at one of the
objects that appears on the map. You don’t have to open
the map in GIANTS Editor and hide everything except
what you want to see.

You just need to follow the same basic steps for opening a
map in GIANTS Editor. Find the I3D file for the object and
open it from the editor. Figure 1-3 shows a mailbox from
the default Farming Simulator map loaded in GIANTS
Editor.

persp
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Figure 1-3: A mailbox object opened in GIANTS Editor.
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When you first load an object in the editor, you may
notice that the object may be really small in the 3D
Viewport or out of view entirely. Fortunately, you can
easily fix it with the following steps:

1. If you can see the object in the 3D Viewport, you
can select it by clicking on it.

If it’s too small to select that way or if it’s not visible
in the 3D Viewport at all, you can click on the object’s
name in the Scenegraph panel and select it that way.

2. With the object selected, you can frame the 3D
Viewport on it using the F hotkey.

Doing so brings the object into view. However more
than likely, the view will be too close to see the entire
object. Using the scroll wheel on your mouse, you
can back away from the object in the 3D Viewport
and make it more visible. For more ways to navigate
the 3D Viewport, refer to the next section.

You may also notice that your object appears really dark.
Most objects don’t emit light, so most object I3D files
don’t include any light in the scene, which can make pre-
viewing an object difficult.

To see the object clearly, you may want to add a light
using the Ctrl+L hotkey combination. You can also add a
light from the Create menu (Create=>Light).

If you're viewing objects from the Farming Simulator data
folder, do not save those object files, especially if you've
made modifications like adding a light. Doing so affects
how the object appears in the game.

Navigating in 3D Space

Being able to move around in the 3D Viewport to see the
map or object from different angles is also important. You
can move around by using the mouse and the Alt key on
your keyboard.
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Having a three-button mouse when working with 3D
software is really in your best interest. These programs
have a tendency to use as many buttons on your com-
puter as they can get. Fortunately, most modern desktop
computers come with three-button mice. (Note: You can
find the third button on most of these mice by pressing
down on the mouse’s scroll wheel.) If you have a laptop,
though, the built-in trackpad doesn’t often have a middle
mouse button. In that case, | highly recommend that you
purchase a proper mouse.

Navigating a 3D scene consists of three main types of
movement:

v Orbiting: The view from the 3D Viewport rotates
around a fixed location. In GIANTS Editor, you orbit
the view by holding Alt while clicking and dragging
your left mouse button.

v+~ Panning: The view from the 3D Viewport always
faces the same direction, but it moves horizontally
and vertically. Imagine that you're stepping side-to-
side or squatting and standing while always looking
the same direction. You pan in GIANTS Editor by
holding Alt while clicking and dragging your middle
mouse button.

v Zooming: The view from the 3D Viewport gets closer
or farther away from a point in 3D space. A quick way
to do this is with your mouse’s scroll wheel. However,
scrolling to zoom snaps in fixed increments. If you
want more fine-grained control, hold Alt while click-
ing and dragging your right mouse button. Zooming
this way is much smoother.

Using Framed Rotate

You can use another option for navigating in the 3D
Viewport: Framed Rotate specifically relates to orbiting in
the 3D Viewport. You can use the F hotkey to frame the 3D
Viewport on the selected object. When you orbit the view
with Framed Rotate enabled (Viewr>Framed Rotate), you
orbit around the last framed location, no matter how far
away you pan from it.



