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Introduction

This book aims at giving insight on a few of the most widely used tools in
the fields of creative coding and DIY digital electronic musical interfaces.
It is a result of personal exploration in these fields and an attempt to gather
information about the combination of the popular prototyping platform,
the Arduino, with the also popular visual programming language for
multimedia, Pure Data (Pd).

The main focus of the book is interactivity with the physical world and
how to make this musical. It is split among several projects where each
project brings a fresh idea on how to combine musical instruments with
computers, whereas the use of programming builds up gradually. Also, this
book uses only open source software, because of the great advantages one
can have from an open source community, but also in order to bring the
cost of every project to its minimum.

The first edition of this book, which was published in late 2015,
used Pd-extended, a version of Pd that included a number of external
packages, in addition to the ones that come with Pd’s core - called Pd-
vanilla. Since then, a lot has changed, and Pd-extended is now no longer
maintained. Still, at the time of writing (early 2024), it is easier than ever
to install Pd-vanilla and any external packages in any operating system
(OS). Additionally, the version of the Arduino Integrated Development
Environment (IDE) has also moved up by a significant number, and it is
now much more feature-rich and easy to use. All this, together with the
advent of artificial intelligence (AI) in the field of creative coding, rendered
this second edition necessary.
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INTRODUCTION

Besides software versions, a significant addition to this second edition
is the Bela, a prototyping platform for interactive musical projects. This is
introduced in Chapter 3, together with the Raspberry Pi, and a project is
built with it in Chapter 9. An extra chapter has been written, focusing on
Al This is Chapter 11. The initial Chapter 5 has been completely removed,
as I felt it didn’t really add to this book. This chapter covered MIDI, which
has been taken up by the second project of Chapter 11.

Chapter 3 of the first edition has been split in two, and now these are
Chapters 3 and 4, where Chapter 3 focuses on embedded computers -
namely, the Raspberry Pi and the Bela - and Chapter 4 focuses on wireless
communication. In addition to the XBee radios used in the first edition,
wireless communication over WiFi has been added, while the Bluetooth
communication has been removed, as it seems to not be very popular and
requires a few steps in its configuration, both in software and hardware,
rendering it not easy enough to include it in this edition.

I hope the reader finds this book useful for their own projects and that
it will kick-start their own endeavors in the fields of creative/interactive
coding and DIY electronics.
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CHAPTER 1

Introduction to Pure
Data

Pure Data (Pd) is a visual programming language and environment for
audio, visuals, and multimedia. It is open source, and it was developed

by Miller Puckette during the 1990s. Pd is a very powerful and flexible
programming language, still actively developed, used by professionals and
hobbyists alike around the world.

Visual programming means that instead of writing code (a series of
keywords and symbols that have a specific meaning in the context of a
programming language), you use a graphical interface to create programs,
where in the most usual cases, a “box” represents a certain function, and
you connect these “boxes” with lines. This kind of programming is also
called data flow programming because of the way the parts of a program
are connected, which indicates how its data flows from one part of the
program to another.

Visual programming can have various advantages compared to textual
programming. One advantage is that a visual programming language
can be very flexible and quick for prototyping, where in many textual
programming cases, you need to write a good number of lines of code
before you can achieve even something simple. Another advantage is
that visual programming can be considered more intuitive than textual

© Alexandros Drymonitis 2024 1
A. Drymonitis, Digital Electronics for Musicians, Maker Innovations Series,
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CHAPTER 1  INTRODUCTION TO PURE DATA

programming. There seems to be a consensus among nonprogrammers
where textual code is considered as something coming out of a horror
movie, making visual programming languages more attractive.

Throughout this book, we will use Pd for all of our audio and
sequencing programming, most of the times in combination with
the Arduino. The Arduino is a prototyping platform used for physical
computing, which enables us to connect the physical world with the world
of computers. A thorough introduction to Arduino is given in Chapter 2.
This chapter is an introduction to Pd, where we will go through its basics,
its philosophy, as well as some general electronic music techniques. If
you are already using Pd and know its basics, you can skip this chapter
and go straight to the next one. Still, if you are using Pd but have a
fuzzy understanding on some of its concepts, you might want to read
this chapter. Mind that the introduction to Pd made in this chapter is
centralized around the chapters that follow, and even though some generic
concepts will be covered, it is focused on the techniques that will be used
in this book’s projects.

In order to follow this chapter and the rest of this book, you will need to
install Pd on your computer. Luckily, Pd runs on all three major operating
systems (OS), macOS, Linux, and Windows. At the time of writing, there are
a few different versions of Pd. The basic one is called Pd-vanilla, and it is the
core on which all other versions are based. This is the version developed
by Miller Puckette. Other versions include Pd-L20rk (standing for Linux
Laptop Orchestra), Purr Data (a Pd-L20rk version for all OSes), and
PlugData. All these extra versions have a different Graphical User Interface
(GUI) than Pd. Pd-L20rk and Purr Data are monolithic versions that ship
with a large collection of external objects (packages) in addition to the core
set of native Pd objects, following the paradigm of the now discontinued
Pd-extended. PlugData ships with a smaller collection of externals, but it
adds the capability of using it as a plug-in inside other software (like Digital
Audio Workstations (DAWs)) or to compile your Pd programs as C/C++
code. PlugData also offers flexibility on the configuration of its GUI.
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Throughout the entire book, we will be using Pd-vanilla. Even though
Pd-vanilla comes with the native Pd objects only, it is very easy to add
external objects, which we will see next. You can download it for free from
its website: https://puredata.info/. You will find two versions of Pd,
vanilla (Pure Data) and Purr Data. Navigate to the download page of Pure
Data and choose the version for your OS. At the time of writing, the latest
Pd version is 0-54.1.

By the end of this chapter, you'll be able to

e Understand how a Pd program works

o Create small and simple programs in Pd
e Find help in the Pd environment

o Create oscillators in Pd

e Make use of existing abstractions in Pd and create
your own

e Realize standard electronic music techniques in Pd

Before We Start

The first thing we need to do is launch Pd and test its audio output. When
launching Pd for the first time, it will ask whether you would like it to
create a folder called Pd inside your Documents folder. Click “OK” as this
is where we will be saving our patches throughout this book. Once this is
done, go to Media » Test Audio and MIDLI... and a window will open (in
Pd jargon, a program we write in Pd is called a patch, and this is what we
will refer to Pd programs from now on). On the left-hand side of this patch,
there is an area labeled “OUTPUT MONITOR” and a radio button with
three options: 80, 60, and off. 80 and 60 refer to decibels (dB), where 100 is
full amplitude. Click one of these two dB values to determine if Pd’s audio
output works properly. You should hear a sine wave at 440Hz.


https://puredata.info/
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If no sound is coming out of your computer, go to Media » Audio
Settings.... Click the button in the Qutput Devices field, and check the
list of available output devices. Choose either your computer’s internal
speakers, or, if you are using an external audio interface and it shows up in
the list, choose that. Click the Apply and OK buttons and see if that works.
If you still don’t get any sound, make sure you do get sound from some
other software, and try different choices in the Qutput Devices list.

We also need to install two externals, one library (a set of external
objects) and a single external. When you launch Pd, all you will see is the
Pd console, shown in Figure 1-1. A window will also pop up, asking you if
you want Pd to create a folder called “Pd” inside your “Documents” folder
and inside there to create a folder called “externals” (from now on, a folder
will be referred to as a directory). Go ahead and click OK. The Pd console is
where certain information is printed while Pd runs, like error and warning
messages. To install the externals we want, we have to go to Help » Find
Externals, and the “deken” plug-in will open, shown in Figure 1-2.

In the top entry, type “zexy” and hit Return (the Enter key). In the
“Search Results” area, you should see an expandable entry. Click the little
arrow on the left of the library name (in our case, “zexy”) to expand its
contents, and choose the topmost item, which should be the most up-to-
date version of the library for your OS. Once you have done that, in the
search entry, at the top of this window, type “comport” Follow the same
procedure to install this one as well. The zexy library is, as itself states, the
Swiss army knife of Pd. We will be using a few objects from this library. The
comport object enables Pd to communicate with the serial ports of your
computer, thus enabling us to communicate with the Arduino.
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Pd 0.54.1 X

File Edit Put Find Media Window Help

Audio off
- Log: 2 — . I DSP

Sl

Figure 1-1. The Pd console
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deken - Find externals X

File Edit

Il I Show all ‘

Search for: " libraries © objects © both
Only install externals uploaded by people you trust.

Search Results ] Log |

Enter an exact library or object name. =
e.g. 'freeverb~'
Use the '*' wildcard to match any number of characters.
e.g. '*-plugin' will match 'deken-plugin’ (and more).
You can restrict the search to only-libraries or only-objects.
To get a list of all available externals, try an empty search.

Right-clicking a search result will give you more options...

You can also search for libraries & objects via your web browser:
https://deken.puredata.info

Rl

Figure 1-2. The deken plug-in

There’s one last thing left to do before we start learning Pd. All external
objects are installed in the “externals” directory, when downloaded from
deken, but Pd doesn’t know it has to look for objects there. In addition to
that, zexy is a single-binary library, which means that all objects of this
library are compiled from one source code file into a single executable file
(called a binary file). Such cases of external libraries need to be treated
differently. Close the deken window, and in the Pd console, go to File >
Preferences, and a submenu will appear, in which you should select “Edit
Preferences.” The window shown in Figure 1-3 will open. Click the “Path”
tab, on the top of this window, and then click “New.” Another window will
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open, where you should navigate to the “zexy” and “comport” directories,
one at a time. Go to the “zexy” directory, and once selected, click OK. A
new entry should appear in the main area of the Preferences window. Do
the same for comport. The directories that appear in this area are now
added to Pd’s search paths, which means that Pd will search there, in
addition to its standard paths, when you try to create an object.

Preferences x

Path | Startup | Audio | MIDI | misc |

~Pd search path for objects, help, audio, text and other files

New... Edit... ‘ Delete ‘

v Use standard paths

Pd Documents Directory

|/home/alex/Documents/Pd Browse

Reset ‘ Disable ‘

Externals Install Directory

|/home,lalex/Documents!Pd!extemaI 5 Browse

Reset ‘ Clear ‘

Cancel ‘ Apply ‘ OK ‘

Figure 1-3. Pd’s Preferences window
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Zexy, being a single-binary library, needs to be added as a library when
Pd starts. In the Preferences window, click the “Startup” tab, click “New,”
and an editable entry will appear. In there, type “zexy” and hit Return. The
word “zexy” should appear in the main area of the window. For all these
settings to become effective, you will need to click the “Apply” button, at
the bottom of the deken window, and then “OK.” Now restart Pd to see if
your changes have been correctly applied. In Pd’s console, you should see a
multiline message about the zexy library, like the one shown in Listing 1-1.
This means that zexy has been correctly installed and imported. You are
now ready to start learning Pd!

Listing 1-1. Message on Pd’s Console When the zexy Library
Is Loaded

VAV,

the zexy external 2.4.2

(c) 1999-2023 IOhannes m zmdlnig
forum: : fiir: :umlaute
iem @ kug

compiled Dec 6 2023

send me a 'help' message

VAV,

Q
Q
Q
Q
Q
Q

Pd Basics: How It Works

Pd consists of several elements that work together to create programs. The
most basic elements are the object and the message. An object is a function
that receives input and gives output. Figure 1-4 shows the osc~ Pd object.

Figure 1-4. A Pd object
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This specific object is a sine wave oscillator with a 440-hertz (Hz)
frequency. There is no need to understand what this object does; we will
go through that in a bit. There are a few things we need to note. First of

” u

all, there is specific text inside the object box, in this case “osc~ 440" “osc”
stands for oscillator, and the ~ (called the tilde) means that this object is
a signal object. In Pd, there are two types of objects: signal and control.
A signal object is a function that deals with signals (a digital form of an
electric signal). A signal object will run its function for as long as the audio
is on (the audio is also called the DSP, which stands for Digital Signal
Processing). A control object is independent of audio and runs its function
only when it is told to. We will get a better picture of the difference between
the two as we go. The last part of the text, “440,” is called an argument. This
is the data that a function receives, and we provide it as an argument when
we want to initialize an object with it. It is not necessary to provide an
argument; when there’s no argument in an object, the object is initialized
with the value(s) of zero (0).

The second main element in Pd is the message, which is shown in
Figure 1-5.

Figure 1-5. A Pd message

It is a little bit different from the object, because on its right side, it is
indented, and it looks a bit like a flag. The message delivers data. There’s
no function here, only the data we write in the message (sometimes
referred to as a message box). One thing the object and the message have
in common is the inlets and the outlets. These are the little rectangles on
the top and the bottom, respectively, of the object and the message. All
messages have the same form, no matter what we type in them. They all
have one inlet to receive data and one outlet to provide the data typed in
them. The objects differ, in the sense that each object has as many inlets as
it needs to receive data for its function and as many outlets as it needs to
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give the output(s) of the function. With the osc~ object, we can see that it
has two inlets and one outlet. The left inlet and the outlet are different than
the right inlet, even though they look alike. The left inlet and the outlet are
signal inlets/outlets, and the right inlet is a control inlet. Their differences
are the same as the signal and control objects. Note that a signal object can
have control inlets/outlets, but a control object cannot have signal inlets/
outlets.

Objects and messages in Pd are connected with lines, which we also
simply call connections. A message connected to the osc~ object is shown

[a40(

0SC~

in Figure 1-6.

Figure 1-6. A message connected to an object

A connection comes out of the outlet of the message and goes to the
inlet of the object. This way, we connect parts of our programs in Pd.

Our First Patch

Now let’s try to make the little program. Launch Pd to see its console. It
is very important to always have this window open and visible, because
we get important information there, like various messages printed from
objects, error messages, and so forth.

Go to File » New to create a new window. You will get another window
that is totally empty (don’t make it full screen because you won’t be able
to see the Pd console anymore). Note that the mouse cursor is a little hand
instead of an arrow. This means that you are in Edit Mode, so you can edit
your patch. In this window, we will put our objects and messages. In this
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