LEARNING MADE EASY

'366‘

SPSS Statistics

dummies

A Wiley Brand

Fine-tune your
interpretation skills

Rehearse the most important
statistical techniques

Produce more effective
tables and charts

Jesus Salcedo, PhD
Keith McCormick






[~~~

1160

SPSS Statistics

Workbook

by Jesus Salcedo, PhD
and Keith McCormick

dummies
A Wiley Brand



SPSS® Statistics Workbook For Dummies®

Published by: John Wiley & Sons, Inc., 111 River Street, Hoboken, NJ 07030-5774, www .wiley.com
Copyright © 2023 by John Wiley & Sons, Inc., Hoboken, New Jersey

Published simultaneously in Canada

No part of this publication may be reproduced, stored in a retrieval system or transmitted in any form or by any means,
electronic, mechanical, photocopying, recording, scanning or otherwise, except as permitted under Sections 107 or 108 of

the 1976 United States Copyright Act, without the prior written permission of the Publisher. Requests to the Publisher for
permission should be addressed to the Permissions Department, John Wiley & Sons, Inc., 111 River Street, Hoboken, NJ 07030,
(201) 748-6011, fax (201) 748-6008, or online at http://www.wiley.com/go/permissions.

Trademarks: Wiley, For Dummies, the Dummies Man logo, Dummies.com, Making Everything Easier, and related trade dress
are trademarks or registered trademarks of John Wiley & Sons, Inc. and may not be used without written permission. SPSS is a
registered trademark of IBM Corporation. All other trademarks are the property of their respective owners. John Wiley & Sons,
Inc. is not associated with any product or vendor mentioned in this book.

LIMIT OF LIABILITY/DISCLAIMER OF WARRANTY: WHILE THE PUBLISHER AND AUTHORS HAVE USED THEIR BEST EFFORTS
IN PREPARING THIS WORK, THEY MAKE NO REPRESENTATIONS OR WARRANTIES WITH RESPECT TO THE ACCURACY OR
COMPLETENESS OF THE CONTENTS OF THIS WORK AND SPECIFICALLY DISCLAIM ALL WARRANTIES, INCLUDING WITHOUT
LIMITATION ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. NO WARRANTY
MAY BE CREATED OR EXTENDED BY SALES REPRESENTATIVES, WRITTEN SALES MATERIALS OR PROMOTIONAL STATEMENTS
FOR THIS WORK. THE FACT THAT AN ORGANIZATION, WEBSITE, OR PRODUCT IS REFERRED TO IN THIS WORK AS A CITATION
AND/OR POTENTIAL SOURCE OF FURTHER INFORMATION DOES NOT MEAN THAT THE PUBLISHER AND AUTHORS ENDORSE
THE INFORMATION OR SERVICES THE ORGANIZATION, WEBSITE, OR PRODUCT MAY PROVIDE OR RECOMMENDATIONS IT
MAY MAKE. THIS WORK IS SOLD WITH THE UNDERSTANDING THAT THE PUBLISHER IS NOT ENGAGED IN RENDERING
PROFESSIONAL SERVICES. THE ADVICE AND STRATEGIES CONTAINED HEREIN MAY NOT BE SUITABLE FOR YOUR SITUATION.
YOU SHOULD CONSULT WITH A SPECIALIST WHERE APPROPRIATE. FURTHER, READERS SHOULD BE AWARE THAT WEBSITES
LISTED IN THIS WORK MAY HAVE CHANGED OR DISAPPEARED BETWEEN WHEN THIS WORK WAS WRITTEN AND WHEN IT IS
READ. NEITHER THE PUBLISHER NOR AUTHORS SHALL BE LIABLE FOR ANY LOSS OF PROFIT OR ANY OTHER COMMERCIAL
DAMAGES, INCLUDING BUT NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR OTHER DAMAGES.

For general information on our other products and services, please contact our Customer Care Department within the
U.S. at 877-762-2974, outside the U.S. at 317-572-3993, or fax 317-572-4002. For technical support, please visit https://
hub.wiley.com/community/support/dummies.

Wiley publishes in a variety of print and electronic formats and by print-on-demand. Some material included with standard
print versions of this book may not be included in e-books or in print-on-demand. If this book refers to media such as a CD or
DVD that is not included in the version you purchased, you may download this material at http: //booksupport.wiley.com.
For more information about Wiley products, visit www.wiley.com.

ISBN 978-1-394-15630-6 (pbk); ISBN 978-1-394-15632-0 (ebk); ISBN 978-1-394-15631-3 (ebk)


http://www.wiley.com
http://www.wiley.com/go/permissions
https://hub.wiley.com/community/support/dummies
https://hub.wiley.com/community/support/dummies
http://booksupport.wiley.com
http://www.wiley.com
http://Dummies.com

Contents at a Glance

Introduction ... 1
Part 1: Getting Dataintoandoutof SPSS . . ....................... 5
cHapTer 1: Working Through Import and Export Challenges . ..., 7
CHAPTER2: DefiNiNg Data. . ... e e e 19
Part 2: Messing withDatainSPSS............................... 35
cHAPTER3: Usingthe Data MenuU ... e e 37
cHAPTER 4:  Putting the Transform MenutoWork. ... 59
cHAPTER 5: Computing Variables ... ... e 87
Part3: AnalyzingData ............. .. ... ... . ... ... ... 119
CHAPTER 6:  USiNg Descriptive Statistics . . ...t e 121
cHapTER 7:  Testing Relationships with the Chi-Square Test of Independence................ 141
cHAPTER 8: Comparing TWo Groups With T-Tests ...ttt 161
cHApTER9: Comparing More Than Two Groups With ANOVA. . ...t 177
cHAPTER 10: Testing Relationships with Correlation....... ... ... .o ... 199
cHAPTER 11: Making Predictions Using Linear Regression. ..., .. 213
Part 4: Producing and EditingOutput ....................... ... 223
cHAPTER 12: Building Graphs with Bars, Lines,andWedges . ..., 225
cHAPTER 13: Building Slightly More Complex Graphs. ... ...t 245
CHAPTER 14: EAItING OULPUL . . ..o e i 275
Part 5: Programming SPSS with Command Syntax .............. 287
cHAPTER 15: Working with Pasted SPSS Syntax . ...t 289
cHAPTER 16: Computing Variables with Syntax . ... 297
Part6:The PartofTens .......... ... ... ... ... ... ... .. ... 305
cHAPTER 17: Ten Tricky SPSS SKills to Practice . ....... o et 307
cHAPTER 18: Ten Practice Certification QUESLIONS . ..ot v it e e i 313






Table of Contents

INTRODUCTION. . ... e e e e 1
ABOUL ThIS BOOK. . . vt e e 1

FOOliSh ASSUMPLIONS . . .o vt e e 2

[cons Used in ThiS BOOK . ... e e 3

Beyond the BOOK . . ...t e 3
Whereto Gofrom Here ... ... 3

PART 1: GETTING DATAINTO AND OUTOFSPSS ................. 5
cuaerer1: Working Through Import and Export Challenges ............... 7
IMPOrtiNg Data. . ..ottt e 8
EXPOrting ReSUILS. . .ot e e e 12

Answers to Problems in Working Through Import and Export Challenges. ....... 14

CHAPTER 2: Defining Data. ... ... 19
Defining Metadata. . ... .oviii i e e 19

Working with Dates and Times ... ...t i e e e en s 22

Copying Data Properties. . . ...ttt et 24

Answers to Problemsin DefiningData. . .........ooiviin i 28

PART 2: MESSING WITH DATAINSPSS . ... ... 35
ciaererz: UsingtheDataMenu. ... 37
SeleCtiNg Data. . . vttt e 37

SPHEEING Data . oottt e 40

Merging Files by Adding Cases. . ...ttt e 42

Merging Files Adding Variables . ... ... i 45

Answers to Problemsin Usingthe DataMenu ............ccoiiiiiiineennn., 49

cuaerera: PUtting the Transform MenutoWork ........................... 59
Counting Case OCCUITENCES . . o vttt ettt et ettt 59
Recoding Variables .. ... .. 62
Recoding into differentvariables ........ ... . . 63

AUtOmMatic reCoding . . . oo vt 65

BINNING . o 68

Answers to Problems in Putting the Transform MenutoWork ................. 73

cuarrers: COmputing Variables..................... 87
Calculatinga New Variable. . . ... e 88
Computing More Complex Variables . ....... ... .o ... 90

Using System Variables. . .. ... oo 92

UsSing String FUNCLIONS .. oot e e e e 95

Using Multiple String FUNCEIONS. . .. .ot e 97

Answers to Problems in Computing Variables ............ . ... .. ... .. ... 101

Table of Contents A"



vi

PART 3: ANALYZING DATA . . ..o e 119

cuarrere: Using Descriptive Statistics ... 121
Level of Measurement .. ...ttt 121
FOCUSING ON FreqUENCIES . .o\ ottt e e e e e e 123
Summarizing Variables with the Descriptives Procedure ..................... 127
WOrking With Z-SCOres .. ...ttt e 129
Answers to Problems in Using Descriptive Statistics . .............. ...t 133
caerer7: T@Sting Relationships with the Chi-Square Test of
Independence ................... 141
Running the Chi-Square Test of Independence. .............covvviieiiio .. 142
Comparing Column Proportions . .. ..ouvuu ittt 146
Creatinga Clustered Bar Chart .. ......oiiiit i e ean 149
Answers to Problems in Testing Relationships with the Chi-Square Test of
INdEPENdENCE ... ot e 153
cuarrers: COmparing Two Groups with T-Tests............................ 161
Running the Independent-Samples T-Test Procedure........................ 162
Running the Paired-Samples T-Test Procedure. .......... ..., 166
Comparing the Means Graphically ........ ... .o 169
Answers to Problems in Comparing Two Groups with T-Tests. ................ 172
cuarrers: Comparing More Than Two Groups with ANOVA ............. 177
Running the One-Way ANOVA Procedure . ... ..ot 177
CondUuCting POSE HOC TSES. . .ottt et e e e e i ean 183
Comparing the Means Graphically ....... ... i 187
Answers to Problems in Comparing More Than Two Groups with ANOVA ...... 190
cuarer 10: Testing Relationships with Correlation......................... 199
Viewing Relationships . .. ... e 200
Running the Bivariate Procedure ........ ...ttt 203
Answers to Problems in Testing Relationships with Correlation ............... 207
cuarrer 11: Making Predictions Using Linear Regression.................. 213
Performing Simple Linear Regression .........ouuuuneiii i, 213
Performing Multiple Linear Regression .........couiiiiinneeinneeenn.. 217
Answers to Problems in Regression . ...t 221
PART 4: PRODUCING AND EDITINGOUTPUT ................... 223
cuarrer 12 Building Graphs with Bars, Lines, and Wedges................ 225
Building Bar Graphs ... ... e 226
Creating Line Charts . ..ot e e e e 229
Making Pie Charts . . ...t 231
Constructing HiStOgrams . . ...ttt e e 234
Answers to Problems in Building Graphs with Bars, Lines, and Wedges ........ 237

SPSS Statistics Workbook For Dummies



cuaerer 13: Building Slightly More Complex Graphs ........................ 245

Building Clustered Graphs . ... ..ot e 245

Creating Multiple Line Charts. .. ..ottt e i n 249

Using Error Bar Charts to Compare Means. ...ttt 252

Viewing Relationships between Continuous Variables ....................... 255
Identifying Outliers with Boxplots. . ... e 258

Answers to Problems in Building Slightly More Complex Graphs .............. 261
ciaerer1a: Editing Output. ... 275
Editing Graphs . ... 275

Editing Tables . . ... 278

Answers to Problems in Editing Output. ...... ... 281

PART 5: PROGRAMMING SPSS WITH COMMAND SYNTAX....... 287
cuarrer 1s: WWOrking with Pasted SPSSSyntax ............................... 289
Pasting ProCeAUIeS . ...ttt e e e 289

Pasting Transformations .. ...ttt i e 291
Controlling Variable View Specifications with Syntax. ........................ 292

Answers to Problems in Pasting and Modifying Syntax....................... 294

cuarer 16: COMputing Variables with Syntax ............................ .. 297
Calculating New Variable with Syntax. . .. ... 297

USing DO IF . . . END IF oot e e e e 300

Answers to Problems in Computing Variables with Syntax.................... 303
PART6: THEPARTOFTENS ..... ... ... ... ... 305
cuarrer 17: T€N Tricky SPSS Skills to Practice................................. 307
Using RECODE INTO SAME . . . . e 308

Using COMPUTE with System Missing and Other Missing Values .............. 308

Merging TwWo or More Files. . . ..ot e e e et 308

Creating Consistent Charts. . ..ottt e e e i e 309

Creating Consistent Tables. . . ... e e 309
Replicating a Multistep ProcessinSyntax ........c.covuiiiin i, 309
Producing Tables with Custom Tables . .......... ... i, 309

Using the TEMPORARY Command .........ouuiiiniiniiniin i, 310
Explaining P-Values to Others . ... ..ot i i 310
Explaining Statistical Assumptionsto Others ......... ... ... i, 311
cuarter 18: T€N Practice Certification Questions............................ 313
Answers to Practice QUEeSHIONS .. vttt i i i e e e e, 317

INDEX ... e 319

Table of Contents  Vii






Introduction

o you need to use IBM SPSS Statistics for school or work and you feel that you need more

practice to become proficient? Maybe you eventually get the results you need when you

work in SPSS, but it feels like you aren’t doing so efficiently. Maybe you’re about to
embark on an important assignment or research project, and you feel like some more practice
(with carefully presented solutions) is just what you need.

Not to worry. Help has arrived. SPSS Statistics Workbook For Dummies is a collection of exercises
and solutions to move you towards mastery with SPSS. It is a companion book to SPSS Statistics
For Dummies, 4th Edition, but you don’t need to read both. (You see more about how the books
work together later in this introduction.)

We (Keith and Jesus) have trained tens of thousands of students during in-person workshops
for SPSS Inc. (before IBM acquired SPSS). That experience, over many years, means we’ve
looked over the shoulders of attendees as they’ve attempted exercises just like these. We can
anticipate possible mistakes before you make them — and if you practice the examples in this
workbook, you won’t make them at all. We’ve used that experience, along with the topics that
IBM has identified as important for certification, to keep you focused on the critical skills for
using SPSS efficiently.

About This Book

This workbook is designed to develop your ability to perform the most common and important
tasks in the efficient use of SPSS Statistics. Like all books in the Dummies series, it features
easy-access organization and doesn’t bog you down in unnecessary details. We carefully listed,
discussed, debated, and narrowed the topics to maximize an efficient investment of your time.

We understand and value academic pursuits, but this is not an academic book. This is an emi-
nently practical book written by two authors who have spent decades leading software training
workshops. However, if you’re a student, a researcher, or an academic, we have you covered.
We explain critical statistical concepts, choosing the right technique, and interpreting your
results. All that and more is explained from a practical point of view.

So why choose this workbook?

¥ Dozens of practical examples with step by step solutions

¥ Advice from two lifelong users of SPSS Statistics

Introduction 1



¥ Topics carefully chosen and prioritized for the tasks you will encounter most often

¥ Tips and tricks to avoid the most common mistakes from two authors who have observed
(and made) every mistake that is possible to make in SPSS

We follow a few conventions in this workbook:

¥ Most chapters in this workbook will have the following repeating structure: explanation,
example, questions, and answers. The answers are found at the end of each chapter. While
skipping around chapters and sections to find what you need is encouraged, you'll probably
have the best luck reading each section, as indicated with a major heading, in its entirety.

3 Most of the exercises use the menus and dialogs, so when we show you a series of
mouse clicks to access a specific area of the menus, we list the steps like this: choose
File > Open = Data and load the GSS2018.sav file.

¥ Two chapters, 15 and 16, focus on using SPSS Syntax. SPSS Syntax programming code
appears inmonofont to help differentiate it from other text.

3 You are encouraged to write directly in this workbook when trying interpretive questions.
When the questions prompt for an interpretation like “Describe your result,” space is
provided for you to write your answer.

Foolish Assumptions

This book is for you if you have IBM SPSS Statistics and want to practice. Because it’s a work-
book, you get dozens of examples to help you prepare data, create variables, produce statistical
analyses, and even write SPSS Syntax. You can even check out practice questions for IBM’s cer-
tification exam in the final section of the book.

This workbook has been written as a companion to the book SPSS Statistics For Dummies,
4th Edition. That book, which is written for first-time users of SPSS, has more theory, over-
view, and initial setup. You aren’t required to have both books, but they make a perfect pair.
SPSS Statistics For Dummies is the best place to start if you are at ground zero. You can start there,
and then try the exercises in this one. Or, and we like this option even better, use them side
by side.

This book is about IBM SPSS Statistics. We sometimes call it SPSS Statistics, or even just

SPSS. You may encounter something called IBM SPSS Modeler. That is different software, and
this book will not discuss SPSS Modeler at all (except just now).

2 SPSS Statistics Workbook For Dummies



Icons Used in This Book

The tip icon marks tips and shortcuts to make working in SPSS Statistics quicker and
easier.

TIP

Remember icons highlight information that’s especially important to know. These reminders
represent best practices in using SPSS.

REMEMBER

ey ) The technical stuff icon indicates information of a highly technical nature that provides helpful
T context. You can skip this info to complete a practice example, but it will help you more fully

tecunicar understand SPSS.
STUFF

& The warning icon tells you to watch out! It notifies you of important information that may save
you headaches when using SPSS.

WARNING

Gb The example icon presents a fully worked-out solution as a reference to assist you with the
practice problems.

EXAMPLE

Beyond the Book

This workbook is just one part of the support we provide for mastering SPSS. For details
about significant updates or changes that occur between editions of this workbook, go to www.
dummies.com, type SPSS Statistics Workbook For Dummies in the Search box, and open the
Download tab on this book’s dedicated page.

That page is also where you’ll find the book’s cheat sheet, which contains advice for exploring
a new data set, identifying which menu to use to perform various important data preparation
operations, and finding the correct graph type for your data by utilizing level of measurement.

You can find a wealth of related information at the companion book’s Dummies page by going to
www . dummies . com and typing SPSS Statistics For Dummies in the Search box. Videos describing
the topics covered in SPSS Statistics For Dummies, 4th Edition and ten SPSS gotchas can be found
at https://keithmccormick.com/SPSS4Dummies.

Where to Go from Here

We wrote this book in a nonlinear way. You can skip around. It’s okay. We skipped around when
we wrote it, too. But it does have a structure. If you have a deep interest in a broad topic, you
might want to complete an entire part of the book.

Introduction 3
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If you need practice getting your data in and set up, check out Part 1. Part 2 is all about creating
variables with the Compute dialog and by using other transformations. If you need to apply a
formula or modify a variable, check out the dozens of examples in this part.

If you need practice producing statistical analyses and interpreting them, you need Part 3.
Part 4 is all about graphing, providing lots of practice making nearly every graph type that
SPSS Statistics supports. You also learn about editing output.

If you are intrigued with Syntax but have been afraid to dive in, see Part 5. You get a chance to
try Syntax and then check your work. Many of the tasks are similar to those in Part 2, except
you work in the Syntax window in Part 5.

In the final section, Part 6, we warn you about skills that are particularly tricky and then offer
some practice questions to help you decide if the IBM SPSS Statistics certification exam is
something you’d like to try.

SPSS Statistics Workbook For Dummies



Getting Data into
and out of SPSS



IN THIS PART . ..

Bring data into SPSS and show results in other
applications.

Define data properties.



IN THIS CHAPTER

» Resolving trouble with delimiters
on import

» Exporting output

Chapter 1

Working Through
Import and Export
Challenges

n this chapter you learn about ways to transfer data into and out of SPSS. Getting data into

SPSS is the first step before any analysis can be done. If the data is available in an SPSS

data file (.sav file extension), bringing that data into SPSS is easy. If your data comes from
another program such as Excel or is in the txt, CSV, or SAS format, you can import that data
into SPSS with just a little more work. The examples in this chapter demonstrate some com-
plications that arise when importing these types of files.

After SPSS analyzes your data and displays results in easy-to-understand tables and graphs,
you might want to use the results in another application to share your findings with others.

This might involve

¥ Formatting tables as cleanly as possible for clarity of presentation and ease of viewing

¥ Exporting output to a file format that can be read by any user, such as Portable Document
Format (pdf)

¥ Doing post-processing on pivot tables in another application, such as Microsoft Excel

CHAPTER 1 Working Through Import and Export Challenges 7



Applications such as Microsoft’s PowerPoint or Word can display the results of your analyses
as plain text, as rich text, or as a metafile, which is a graphical representation of the output.
Pivot tables can be pasted or exported to Microsoft Excel with each cell of the pivot table in a
separate Excel cell.

In this chapter, you both copy and paste as well as export your SPSS output to another
application.

Importing Data

8

This section contains an example of a procedure you can follow to read data from Excel files
into SPSS. Along the way, SPSS keeps you informed about what’s going on so there won’t be
any big surprises at the end. Here are a few things to consider to make the import process a
little easier:

»
»

»

»

»

When reading the Excel file into SPSS, the file must not be open in Excel.

Variable names are read from the first row of the Excel spreadsheet. However, the blank
spaces in the variable names are removed because blanks are not allowed in SPSS variable
names.

The measurement levels of variables are assigned based on the criterion defined in Data
options. Variables with a small number of values are set to nominal. Variables with many
values are set to scale.

SPSS reads only the values in the cells of the spreadsheet. Formulas in the spreadsheet will
be computed and these computed values imported to SPSS.

The formulas and other spreadsheet characteristics associated with the cells are not
imported to SPSS.

see how the file is structured.

We strongly recommend opening the original file in the software where it is stored so you can

TIP

In the following example, the Excel workbook has two worksheets: The first is the title page
and the second contains the data. Do the following to read this data into SPSS:

1.

2.

Choose File > Import Data-> Excel.

Select the GSS2018 Title.xlsx file and then click Open.

You can download the file from the book’s companion website at www.dummies . com/go/
spssstatisticsworkbookfd.

In the Worksheet drop-down list, select the GSS2018 worksheet.

An Excel file can contain more than one worksheet, and you can choose the worksheet
you want from the drop-down list, as shown in Figure 1-1.

PART 1 Getting Data into and out of SPSS
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Also, if you’ve elected to read only part of the data, use the Range drop-down list to
specify the range of Excel cells that you want to import. Use the five check boxes, as
needed, to specify whether the names of variables appear in the first row, the
percentage of data to use to determine the variable type, and how to handle leading
or trailing spaces.

@ Inspect the data preview to make sure the variables and data will be read properly.

TIP

[ ] L ] Read Excel File

/Users [jesussalcedo /Desktop/Work/Dummies Workbook/GSS2018_Title.xlsx

Worksheet: (S52018 [A1:KS2349] =
Range:  |Title [AL:AL]

GS52018 [A1:K52349]
¥ Read variable names from first row of data

# Percentage of values that determine data type: 95

¥ lgnore hidden rows and columns
Remove leading spaces from string values

Remove trailing spaces from string values

Preview

& ADUL... & AFTE.. & AGE | & AGED & AGEK... & ANCE... & ARTH
s 1 |43 0 0 4 2 [=
2 0 |74 1 21 0 0

2 1 |42 11 35 3 2

2 ] 63 1 32 0 1

2 0 71 2 0 0 0

2 2 |67 0 27 3 0

2 ] 59 1 1R )] 2 x
N I¥]

Final data type is based on all data and can be different from the

FIGURE 1_'1: preview, which is based on the first 200 data rows. The preview
Select which displays only the first 500 columns.
datain the
spreadsheet to Cancel Paste Reset
include.

4. Click the Read Variable Names from the First Row of Data check box.
5. Click OK.
Your data appears in the SPSS window.

6. Switch to the Variable View tab to examine the variable definitions and make any
changes.

SPSS makes a bunch of assumptions about your data, and some of those assumptions
are probably wrong.

7. Save the file using your chosen SPSS name, and you’re off and running.

CHAPTER 1 Working Through Import and Export Challenges 9



See the following for an example of importing data into SPSS.

databases can save their contents in a text file format. Commonly used delimiter
characters are tabs or commas.

Q. Text files are another common source of data. Many spreadsheet programs and

EXAMPLE

Import the file GSS2018.csv to SPSS. Note that the comma-separated file has variable
names in the first row. The variable names are in the first row and the data begins
in row 2.

A. Do the following:

-]

. Choose File=> Import Data=> CSV Data.
b. Select the GSS2018.csv file, and then click Open.

The Text Import Wizard appears, allowing you to load and format your data.
Examine the input data. The screen lets you peek at the contents of the input
file so you can verify that you’ve chosen the right file.

c. Click Advanced Options (Text Wizard). Examine the input data.

If your file uses a predefined format (it doesn’t in this example), you can select it
here and skip some of the later steps.

d. Click Continue.
e. Specify that the data is delimited and the names are included.

SPSS takes a guess, but you can also specify how your data is organized. It can
be divided using commas (as in this example), spaces, tabs, semicolons, or some
combination. Or your data may not be divided — it may be that all the data items
are jammed together and each has a fixed width. If your text file includes the
names of the variables, you need to tell SPSS.

f. Click Continue.
g. Specify how SPSS should interpret the text.
You can tell SPSS something about the file and which data you want to read.

Perhaps some lines at the top of the file should be ignored — this happens when
you’re reading data from text intended for printing and header information is at
the top. By telling SPSS about it, those first lines can be skipped.

Also, you can have one line of text represent one case (one row of data in SPSS), or
you can have SPSS count the variables to determine where each row starts.

And you don’t have to read the entire file — you can select a maximum number of
lines to read starting at the beginning of the file, or you can select a percentage of
the total and have lines of text randomly selected throughout the file.

h. Click Continue.

i. Specify tab as the delimiter.

10 PART 1 Getting Data into and out of SPSS



REMEMBER

REMEMBER

-
.

SPSS can use commas, spaces, tabs, and semicolons as delimiting characters. You
can even use some other character as a delimiter by selecting Other and then typ-
ing the character. You can also specify whether your text is formatted with quotes
(which is common) and whether you use single or double quotes.

Strings must be surrounded in quotes if they contain any of the characters being
used as delimiters.

Click Continue.
If necessary, change the variable name and data format.

SPSS makes a guess for the type of each variable. To change a name, select it in
the column heading at the bottom of the window, and then type the new name in
the Variable Name field at the top. If you need to change the format, use the Data
Format drop-down list.

You can also change the data types later in the Variable View tab of the Data Editor
window.

Click Continue.
In the Would You Like to Save This File Format for Future Use? section, click No.

Saving the file format for future use is something you would do if you were load-
ing more files of this same format into SPSS — it reduces the number of questions
to answer and the amount of formatting to do next time.

Click the Done button.

Look at the data, and correct the data types and formats, if necessary. Then save it
all to a file by choosing File=> Save As.

[ ] [ ] Read CSV File

File: G552018.csv

ADULTS AFTERLIF,AGE AGED,AGEKDBRN, ANCESTRS ,ARTHRTIS, ASTROLGY,ASTROSCI, A<
1,1,89,1,0,4,0,2,8,5,8,7,98,8,0,0,1,0,0,1,0,2,1,0,2,0,1,0,0,2,0,2,1,2,1,2,4,4,2,2,3,2,0,
1,2,56,2,17,4,0,2,3,5,0,8,8,98,0,0,1,0,0,1,8,5,3,0,2,0,2,0,0,2,0,1,3,2,5,3 4,2,2,1,3,3,
1,1,67,0,20,1,0,1,1,3,7,8,8,8,0,0,1,0,0,2,3,3,3,0,2,0,2,0,0,1,0,0,3,0,2,0,5,3,0,0,0,0,9
1,1,57,0,04,0,2,3,5,08,1,1,0,0,1,0,0,2,0,3,1,0,2,0,2,0,0,1,0,0,3,0,3,0,4,3,0,0,0,0,14
1,8,59,2,25,2,2,2,3,1,3,1,1,1,0,2,2,8,0,1,2,8,3,3,2,0,2,2,1,1,8,1,3,2,3,2,3,2,0,3,2,2,5
2,0,22,2,0,0,2,0,0,0,6,0,0,0,0,2,1,3,3,2,0,3,2,0,0,0,0,3,0,2,4,1,0,2,0,1,0,0,2,1,1,1,19

9,
2,

"

A
¥ First line contains variable names

Remove leading spaces from string values

Remove trailing spaces from string values
Delimiter between values: Comma ~
Decimal symbol: Period ~
Text Qualifier: Double quote ~
Percentage of values that determine data type: 95

¥ Cache data locally

{Advanced Options(Text Wizard)

Cancel i Paste

CHAPTER 1 Working Through Import and Export Challenges
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e Import the GSS2018.xIsx file to SPSS. This example has one worksheet, the variable
names are in the first row, and the data begins in row 2.

a Import the GSS2018 extra title.xlIsx file to SPSS. This example has two worksheets in the
Excel workbook. The first worksheet is the title page. The second worksheet contains
the data, with the variable names in the first row and the data beginning in row 5.

e Import the GSS2018.dat file to SPSS. This file has a DAT format. The variable names are
in the first row and the data begins in row 2.

e Import the GSS2018 lines.txt file to SPSS. This file has a TXT format. The variable
names are in the first row and the data begins in row 3.

Exporting Results

If you have a single table or a small number of tables, you can copy and paste these directly into
a file opened in another application. Alternatively, SPSS provides an export facility to export
large numbers of tables and charts into a file in a variety of common formats: Excel, Portable
Document Format (PDF), HTML, text, Microsoft Word, and PowerPoint files.

1. Choose File => Open => Output and load the Chapter 1 Output.spv file.

Download the file at www.dummies.com/go/spssstatisticsworkbook fd.
Select the R’s highest degree frequency table.
Choose Edit=> Copy.

Switch to Word or another word-processing application.

EAE DA L

Choose Edit-> Paste Special.

When copying and pasting SPSS pivot tables, always use Paste Special because it
provides various options for displaying the table.

ne 6. Choose Formatted Text (RFT).

The table is pasted and looks like a Word table that can be edited, as shown in

Figure 1-2.
R's highest degree
Frequenc Valid Cumulative
y Percent  Percent Percent

Valid LT HIGH 262 11.2 11.2 11.2

SCHOOL
HIGH SCHOOL 1178 50.2 50.2 61.3
JUNIOR 196 8.3 8.3 69.7

COLLEGE
FIGURE 1.2: BACHELOR 465  19.8 19.8 89.5

Pasting a table
in Microsoft GRADUATE 247 10.5 10.5 100.0
Word. Total 2348 100.0 100.0
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See the following for an example of taking SPSS output and bringing into another application.

db Q. Using the Chapter 1 Output.spv file, copy the graph for R’s highest degree and paste it
into Word.

EXAMPLE A, Select and copy the graph. Then go to Word and choose Edit+> Paste (or Paste Special).

R's highest degree

0

Percent
H

UNIOR
OLLEGE

R's highest degree

Charts are always pasted as images that cannot be edited.

REMEMBER

Using the Chapter 1 Output.spv file, copy the R’s highest degree frequency table and
paste in Word as a picture.

Using the Chapter 1 Output.spv file, copy the R’s highest degree frequency table and
paste it in Excel as a table using Unicode Text.

Using the Chapter 1 Output.spv file, copy the R’s highest degree frequency table and
paste it in Excel as a picture.

° Export the Chapter 1 Output.spv file to Word.
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Answers to Problems in Working Through
Import and Export Challenges

Choose File=> Import Data=> Excel. Click the Read Variable Names from the First Row of Data
check box.

@ Read Excel File

fUsers/jesussalcedo/Desktop /Work/Dummies Workbook/GS552018.xIsx
Worksheet: |GS52018 [A1KS2349] %
Range:
¥ Read variable names from first row of data
+ Percentage of values that determine data type: 95
« Ignore hidden rows and columns

Remove leading spaces from string values

Remove trailing spaces from string values

Preview

|¢” ADUL... & AFTE... & AGE | & AGED & AGEK..#
1 5 1 43 0 0 4 [«
2 2 i 74 1 21 0
3 2 1 42 1 35 3
4 2 i 63 1 32 0
5 2 0 71 2 (i} 0
6 2 2 67 0 27 3
7 2 n 59 1 1R (] b
W Fl

Final data type is based on all data and can be different from the
preview, which is based on the first 200 data rows. The preview
displays only the first 500 columns.

_ Help Cancel  Paste | [Reset [ OK ]

Choose File=> Import Datar> Excel. Select the GSS2018 worksheet. Click the Read Variable
Names from the First Row of Data check box. After the data has been imported, delete the
extra rows that appear at the beginning of the file.
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@ Read Excel File

JUsers/jesussalcedo/Desktop /Work/Dummies Workbook/G552018 extra title.x|sx
Worksheet: [E882018 ALKSZ3 ST

Range:

¥ Read variable names from first row of data

¥ Percentage of values that determine data type: 95

¥ Ignore hidden rows and columns
Remove leading spaces from string values
Remove trailing spaces from string values
Preview

& ADUL.. & AFTE.| & AGE | & AGED & AGEK..&" ANCE.. & ARTH... &

-

43 0 0 4

5 1 2 2
2 0 74 1 21 0 0 0
2 1 42 1 35 3 2 2
O I*]

Final data type is based on all data and can be different from the preview,
which is based on the first 200 data rows. The preview displays only the
first 500 columns.

Help Cancel | Paste Reset |

Choose File=> Import Data=> Text Data. Use the defaults but specify that tab is the only delim-
iter. Deselecting space as a delimiter will remove the extra column.

Always check the data preview to make sure you do not have any columns that do not have
variable names. If this occurs, you did not select the correct delimiter.

TIP
L Text Import Wizard - Delimited Step 4 of 6
Which delimiters appear between variables? What is the text qualifi...
¥ Tab YiSpace | @None
Comma Semicolon © Single quote
Other: ) Double quote
© Other:

Leading and Trailing Spaces
Remove leading spaces from string values
Remove trailing spaces from string values

Data preview

SU...|YEARVAL |YOUSUP |ZODIAC |Predicte.. |Predicte...| V306
-1 11
-1
-1

-1

9999999
-1
-1
-1
=1
=]

TN N Y. YN
=
K "0

o000 00O0O 00O

Help Cancel J Go Back ][Continue]
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Choose File=> Import Data=> Text Data. Use the defaults but specify that the first case of data
begins on line 3. Also specify that tab is the only delimiter.

® Text Import Wizard - Delimited Step 3 of 6
The first case of data begins on which line number? B |‘-

How are your cases represented?
@ Each line represents a case
O A specific number of variables represents a case:

How many cases do you want to import?
@ All of the cases

O The first cases.
© A random percentage of the cases (approximate): = %
Data preview
0 10 20 30 40 50 t
NS N TR ST TR PR TS T T T T T e
|_Name| [ADULTS AFTERLIF AGE AGED AGEKDBRN ANCE=
3| 5 1 43 %] '} 4 2 2
4| 2 ] 74 1 21 ] ] @
5| |2 1 42 1 35 3 2 2
6| 2 '] 63 1 3z i} 1 @
7| |2 @ 71 2! [ ) 8 [
i IG
| Help | Cancel || Go Back [Continue]

Select and copy the R’s highest degree frequency table. Then go to Word and choose
Edit= Paste Special and select Picture. You would choose to copy SPSS output as a
picture if you did all your editing in SPSS and would like the output to appear exactly
as it appeared in SPSS.

R's highest degree

Cumulative

Frequency Percent Valid Percent Percent
Valid LT HIGH SCHOOL 262 11.2 11.2 11.2
HIGH SCHOOL 1178 50.2 50.2 61.3
JUNIOR COLLEGE 196 8.3 8.3 69.7
BACHELOR 465 19.8 19.8 89.5
GRADUATE 247 10.5 10.5 100.0

Total 2348 100.0 100.0
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Select and copy the R’s highest degree frequency table. Then go to Excel, choose Edit> Paste
Special, and select Unicode Text. You would use the Unicode Text option so that you can
further edit your tables in Excel.

_1 A B G D E F G
1 |R's highest degree
2 Frequency Percent Valid Percent Cumulative Percent
3 |Vvalid LT HIGH SCH 262 11.2 11.2 11.2
4 HIGH SCHOC 1178 50.2 50.2 61.3
5 JUNIOR COLL 196 8.3 8.3 69.7
6 BACHELOR 465 19.8 19.8 89.5
7 GRADUATE 247 10.5 10.5 100
8 Total 2348 100 100
9

Select and copy the R’s highest degree frequency table. Then go to Excel, choose Edit> Paste
Special, and select Picture. You would choose to copy SPSS output as a picture if you did all
your editing in SPSS and would like the output to appear exactly as it appeared in SPSS.

] A B © D A F H
; R's highest degree

3 Cumulative
4 Frequency Percent  Valid Percent Percent

Z Valid LT HIGH SCHOOL 262 11.2 11.2 11.2
7 HIGH SCHOOL 1178 50.2 50.2 61.3
g JUNIOR COLLEGE 196 8.3 8.3 69.7
o BACHELOR 465 19.8 19.8 89.5
= GRADUATE 247 10.5 10.5 100.0
g Total 2348 100.0 100.0

L4

To export your output from SPSS to Word:

a. Choose File= Export.

b. In the Objects to Export section, select the items to include in the output. For the exam-
ple, select All Visible.

c. In the Document section’s Type drop-down list, choose Word/RTF.

d. Click the Browse button, select the directory and name of the exported file (SPSS Output
Export to Word), and then click Save.

e. Click OK.
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f. To view the exported file, open Microsoft Word.

The exported Word file contains the tables and graph that make up the Chapter 1
Output.spv file. The tables can be edited with the Microsoft Word table editor because
the tables were exported as text, not as a picture.

" SPSS Output Export to Word.doc [Compatibility Mode]
q - E & ook @
bles | Charts SmartArt Review

Paragraph Styles

‘ AaBbCcDd AaBbCeDd |AaBbCcDd

Heading 2 Heading 3 Normal

R T R I

Frequencies
Statistics
R's highest degree
N Valid 2348
Missing 0
R's highest degree
Cumulative
Frequency Percent Valid Percent Percent
Valid LT HIGH SCHOOL 262 11.2 11.2 11.2
HIGH SCHOOL 1178 50.2 50.2 61.3
JUNIOR COLLEGE 196 8.3 8.3 69.7
BACHELOR 465 19.8 19.8 89.5
GRADUATE 247 10.5 10.5 100.0
Total 2348 100.0 100.0
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IN THIS CHAPTER

» Defining variables

» Seeing how to work with dates
and times

» Finding out how to copy data
properties

Chapter 2
Defining Data

PSS data has three major components: cases (Chapter 3), variables (Chapters 4 and 5), and
metadata (Chapter 2). Metadata consists of your variable attributes, or definitions. Met-
adata tells SPSS how a variable is defined and how it can be used. Without a definition, a
number serves no purpose. For example, the number 34 could be the number of tickets pur-
chased or the number of sales in the last hour; therefore, a variable’s definition is important.

In this chapter, you learn about variable definitions, or attributes. You also work with date and
time variables. Finally, because defining data can be time-consuming, we demonstrate a spe-
cial shortcut menu for copying your data and variable definitions from one dataset to another.

Defining Metadata

Entering data into SPSS is a two-step process. First, you define what sort of data you’ll be
entering. Then you enter the values. In this section, we briefly describe some of the most
important variable attributes in the Variable View tab of Data Editor.

Each variable characteristic has a default, so if you don’t specify a characteristic, SPSS uses the
default:

3 Name: Every variable must have a unique name. Following are some handy hints about
names:

You can use characters in a name, such as @, #, and $, as well as the underscore
character () and numbers. However, variable names can't start with these special
characters.
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Be sure to start every name with a letter, not a number.

You can't include spaces anywhere in a name, but an underscore is a good substitute.

¥ Type: Most data you enter will be regular numbers. Data such as currency must be dis-

played in a special format, and data such as dates require special formats so they can be
used in calculations. For this type of data, you simply specify what type of data you have,
and SPSS takes care of the details for you.

¥ Width: The Width column in the definition of a variable determines the number of char-

acters used to display the value. If the value to be displayed is not large enough to fill the
space, the output will be padded with blanks. If it's larger than you specify, it either will be
reformatted to fit or asterisks will be displayed.

3 Decimals: The Decimals column contains the number of digits that appear to the right of

the decimal point when the value appears onscreen.

3 Label: The name and the label serve the same basic purpose: They're descriptors that iden-

tify the variable. The difference is that the name is the short identifier and the label is the
long one.

3 Values: The Values column is where you assign labels to all possible values of a variable.

Normally, you make one entry for each possible value that a variable can assume. For
example, for a variable named Sex, you could assign the value 1 to the Male label and the
value 2 to the Female label.

¥ Missing: You can specify codes for missing data and SPSS will ignore this value when per-

forming calculations.

3 Measure: Your value for the Measure attribute specifies the level of measurement of your

variable. Following are the level of measurement options in SPSS:

Nominal: A value that specifies a category or type of thing. You can have 0 represent No
and 1 represent Yes.

Ordinal: A value that specifies the position, or order, of something in a list. For example,
first, second, and third are ordinal numbers.

Scale: A number that specifies a magnitude. The scale can be distance, weight, age, or a
count of something.

Follow these steps to define a label for a value:

Choose File = Open => Data and load the Happy.sav file.

You can download the file from the book’s companion website at www.dummies . com/go/
spssstatisticsworkbookfd.

Click the Variable View tab of Data Editor.
Click in the Value cell for the Happy variable to open Value Labels dialog.
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